harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Petrenko" <alexey.a.petre...@gmail.com>
Subject Re: [eclipse] Eclipse 3.3 crashes on current Harmony
Date Wed, 05 Sep 2007 02:15:58 GMT
2007/9/4, Gregory Shimansky <gshimansky@gmail.com>:
> Gregory Shimansky wrote:
> > It seems to be a bug in verifier, but there weren't any changes in
> > verifier recently, so I am not sure it is a regression. Probably this
> > bug was hidden and didn't show up until recently.
>
> BTW, building DRLVM with -Duse_original_verifier=true allows eclipse 3.3
> to start. I think that maybe switching back to older verifier again
> might improve the situation.
Yes, this helps. -noverify should also help in this case.

I've created HARMONY-4738 to track the issue.
It would be nice if someone familiar with the verifier could fix the issue.

Thanks in advance.

SY, Alexey

https://issues.apache.org/jira/browse/HARMONY-4738

>
> >> 2007/9/4, Alexey Petrenko <alexey.a.petrenko@gmail.com>:
> >>> Yes, looks like we really have a regression.
> >>> I've tried Eclipse with M2 and recent classlib with j9 and works in
> >>> both cases. But silently crashes silently in the very beging. Even
> >>> without trace in configuration directory.
> >>>
> >>> So we need to investigate the issue.
> >>>
> >>> Any help is welcome :)
> >>>
> >>> SY, Alexey
> >>>
> >>> 2007/9/4, Tim Ellison <t.p.ellison@gmail.com>:
> >>>> Leo Li wrote:
> >>>>> On 9/4/07, Alexey Petrenko <alexey.a.petrenko@gmail.com> wrote:
> >>>>>> Guys,
> >>>>>>
> >>>>>> I've tried to run In Harmony with Eclipse bundle on the recent
> >>>>>> harmony/drlvm build but it crashes silently in the very begining.
> >>>>>> I would say that this is very serious regression for us.
> >>>>>>
> >>>>>> I'll continue investigation but it would be nice if someone
will try
> >>>>>> to investigate it in the same time.
> >>>>>>
> >>>>>> Thanks in advance.
> >>>>>>
> >>>>>> SY, Alexey
> >>>>>>
> >>>>>  Yes, it is a serious regression. And do you know when it start
to
> >>>>> fail?
> >>>>>   I will try it when I go to office tomorrow since I have no classlib
> >>>>> on hand. Not sure whether I can help.:)
> >>>> FYI: It's working ok for me on the current HEAD of classlib (r572680)
> >>>> with the IBM VME.
> >>>>
> >>>> Regards,
> >>>> Tim
> >>>>
> >>
> >
> >
>
>
> --
> Gregory
>
>

Mime
View raw message