harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stepan Mishura" <stepan.mish...@gmail.com>
Subject Re: [jira] Created: (HARMONY-4832) [buildtest][eut] text.xml should be patched with J2SE-5.0 to run EUT3.3 on Harmony
Date Fri, 21 Sep 2007 08:12:46 GMT
Hi Vladimir,

May be I'm missing something (I didn't look into the build script and
tests deeply. I only quickly reviewed test.xml for EUT 3.3) but my
impression Eclipse unit tests have concept of "running VM" and "tested
VM".

As I see there is a shell script ('runtests') that picks up java
('vmcmd' property ) from PATH to run launcher. So we can call  'vmcmd'
property  "running VM".

Also in the eclipse-testing/test.xml I see
<target name="setJVMfromUserSpecified" if="jvm">

And the property 'jvm' is set up before launching test suite, for example

<target name="jdtcorebuilder" depends="setJVMProperties">
    <!--Run with 1.5 vm if it is available-->
    <condition property="jvm" value="${J2SE-5.0}">
        <isset property="J2SE-5.0"/>
    </condition>
    <runTests testPlugin="org.eclipse.jdt.core.tests.builder" />
</target>

So I assume that 'jvm' value is used to run tests. Am I correct?
If yes then we don't need to patch test.xml. IMO it is enough to set
jvm in 'properties.file'

Also from the first glance it should work for EUT 3.2 too. Correct?

Thanks,
Stepan.

-----Original Message-----
From: Vladimir Beliaev (JIRA) [mailto:jira@apache.org]
Sent: Friday, September 21, 2007 1:08 AM
To: commits@harmony.apache.org
Subject: [jira] Created: (HARMONY-4832) [buildtest][eut] text.xml
should be patched with J2SE-5.0 to run EUT3.3 on Harmony

[buildtest][eut] text.xml should be patched with J2SE-5.0 to run
EUT3.3 on Harmony
----------------------------------------------------------------------------------

                 Key: HARMONY-4832
                 URL: https://issues.apache.org/jira/browse/HARMONY-4832
             Project: Harmony
          Issue Type: Bug
          Components: build - test - ci
         Environment: any
            Reporter: Vladimir Beliaev


Ok, the less magic the better. There is no concept of "running VM" and
"tested VM" for EUT. Instead all EUT are run on the same java taken
from PATH. Still some tests requires Java5.0, so if J2SE-5.0 property
is specified then these tests are run on java pointed by this
property.

This trick is used to "point" EUT to Harmony, i.e each EUT test suite
(in eclipse-testing/test.xml) must have J2SE-5.0 property specified.

So while BTI installation (executing "setup" tag from
tests/eut/build.xml) the eclispe-testing/test.xml must be patched.

Such a patching was done for EUT3.2. One need to add it for EUT3.3.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Mime
View raw message