harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: [drlvm] Eclipse debugger crashes after recent DRLVM update
Date Wed, 01 Aug 2007 07:00:50 GMT
Ivan,
Thanks!

On 8/1/07, Ivan Popov <ivan.g.popov@gmail.com> wrote:
> Alexei,
>
> Such error occurs when JDWP agent from RI is used with DRLVM. It seems
> you are missed jdwp.dll/libjdwp.so in your Harmony JDK, so it's found
> in RI mentioned in your PATH. Please use federated build to make
> Harmony JDK with JDWP agent included.
>
> Thanks.
> Ivan
>
> On 7/31/07, Alexei Fedotov <alexei.fedotov@gmail.com> wrote:
> > Gregory, Alexey,
> >
> > When running EGA scenario [1] I see the following problem on Linux 32:
> >
> > JDWP exit error JVMTI_ERROR_unknown(70007): on raw monitor wait
> > FATAL ERROR occurred in native method: JDWP on raw monitor wait,
> > jvmtiError=JVMTI_ERROR_unknown(70007)
> >
> > This seems to be another recent JVMTI problem. I don't have a short
> > reproducer though.
> >
> > Thanks, Alexei
> >
> > [1] H-3467, http://issues.apache.org/jira/browse/HARMONY-3467
> >
> >
> > On 7/31/07, Gregory Shimansky <gshimansky@gmail.com> wrote:
> > > Alexey Petrenko wrote:
> > > > 2007/7/31, Alexey Petrenko <alexey.a.petrenko@gmail.com>:
> > > >> Guys,
> > > >>
> > > >> I've just updated drlvm on linux and tried to debug small application
> > > >                                         ^^^^^ = Windows :)
> > > >> with Eclipse.
> > > >> It stopps ok on breakpoin but then vm fails on step-over or step-into
> > > >> commands with the following output:
> > > >>
> > > >> === cut ===
> > > >> Windows reported exception: 0xc0000005
> > > >> Registers:
> > > >>    EAX: 0x00000000, EBX: 0x00000000, ECX: 0x032162c8, EDX: 0x0012d720
> > > >>    ESI: 0x000005ac, EDI: 0x031b1770, ESP: 0x0012d694, EBP: 0x032134d0
> > > >>    EIP: 0x005115a4
> > > >> Stack trace:
> > > >>  0: method_is_native
> > > >> (c:\users\cap\harmony\working_vm\vm\vmcore\src\class_support\c_interface.cpp:258)
> > > >>  1: ?? (??:-1)
> > > >> === cut ===
> > > >>
> > > >> Is this known issue?
> > >
> > > I haven't seen it. One crash I am aware of is in HARMONY-4533 but it has
> > > a different stack trace. Could you please create a new JIRA with details
> > > about VM build, mode, debugger application and eclipse version that you
> > > were using?
> > >
> > > --
> > > Gregory
> > >
> > >
> >
> >
> > --
> > With best regards,
> > Alexei,
> > ESSD, Intel
> >
>


-- 
With best regards,
Alexei,
ESSD, Intel

Mime
View raw message