harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Beliaev" <vladimir.k.beli...@gmail.com>
Subject Re: [drlvm][init] -XX:vm.dlls is proposed to be -XX:gc.dll
Date Mon, 02 Jul 2007 14:12:13 GMT
The patch is attached to http://issues.apache.org/jira/browse/HARMONY-3934

Thanks
Vladimir Beliaev


2007/6/27, Vladimir Beliaev <vladimir.k.beliaev@gmail.com>:
>
> Thank you for answer, Xiao Feng.
>
> Since nobody objects I'm preparing property renaming patch...
>
> Automated scripts holders - please be aware about this & get the related
> scripts ready for update.
> (I thing running with gc_cc.dll scripts are to be affected only)
>
> Thanks
> Vladimir Beliaev
>
> 2007/6/26, Xiao-Feng Li <xiaofeng.li@gmail.com>:
> >
> > Makes sense to me. The original option has unclear semantics. If some
> > dlls are needed, they should be loaded by their requestor explicitly
> > or by their requestor's command option. For example, if gc needs
> > additional dlls, it can specify that as -XXgc.other_dlls=xxx; but this
> > is a gc specific option, there is no need for the VM to have a general
> > option for them.
> >
> > Thanks,
> > xiaofeng
> >
> > On 6/25/07, Vladimir Beliaev <vladimir.k.beliaev@gmail.com> wrote:
> > >  *I'd like to rename -XX:vm.dlls to -XX: gc.dll, because:*
> > > (I'm reposting my question in the e-mail with right subject...)
> > >
> > > right now the http://harmony.apache.org/cmd_options.html says about
> > this
> > > property:
> > >
> > >   *-XX:vm.dlls=<list> * A PATH_SEPARATOR-delimited list of modular
> > dynamic
> > > libraries (GC/etc.) to load at startup.
> > >
> > > In fact its default value is "gc_gen.<dll>'. If one sets it to any
> > valid
> > > 'foo.<dll>' (like -XX:vm.dlls="foo.dll") then the "gc*.dll" is not
> > found,
> > > "gc_init" function pointer is not set & DRLVM crashes with 0x00000
> > address
> > > access (HARMONY-3934)... Also there can be only 1 GC.dll in DRLVM now,
> > so it
> > > should be "gc.dll" but not a not a "gc.dlls"...
> > >
> > > So in fact this 'vm.dlls' property semantics is: "set GC dll here".
> > *That's
> > > why I propose to rename it.*
> > >
> > > *Please pay attention that:*
> > >
> > > 1. it would affect the "running scripts" (like Cruise Control ones) -
> > please
> > > speak up if you have a procedure proposal for this renaming (or we
> > just may
> > > agree on commit time).
> > >
> > > 2. one may use this -XX:vm.dlls to set own DLL (other then GC one) -
> > please
> > > speak up if it is true & provide the particular example.
> > >
> > > *Please note that we also have:*
> > >
> > > -XX:em.dll=<dll-path> to set Execution Manager dynamic library
> > > -XX:vm.other_natives_dlls=<dll-path-list> - I know the use case: set
> > the
> > > classlib native libraries to be preloaded during VM startup (I need to
> >
> > > double check if it is still used)...
> > >
> > > Thanks
> > > --
> > > Vladimir Beliaev
> > > Intel Middleware Products Division
> >
> >

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message