harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: [classlib] Bare minimum to run Eclipse
Date Sat, 28 Jul 2007 20:56:46 GMT
Rodney Dowdall wrote:
> I'm just wondering, what are the necessary libraries in order to run
> Eclipse with Harmony on top of J9 with jclMax?

That question is not as simple as it may appear <g>.

What do you mean by "Eclipse" (the platform only, or JDK, CDT, TPTP,
BIRT, ...)? and people on this list are unlikely to know the IBM term
"jclMax".

If you are intent on using jclMax then we can move the conversation
off-list, but could I recommend picking up /all/ the required class
libraries from Harmony?  Harmony's modular architecture allows you to
choose the project's DRLVM or IBM J9 VM [1] or BEA JRockit VM [2].  It
should be noted though that the downloadable IBM and BEA VMs come with
evaluation-only style licenses.

[1] http://www.ibm.com/developerworks/java/jdk/harmony/
[2] http://dev2dev.bea.com/jrockit/jrockitVM/

> I'm thinking:
> 
<snip>
> 
> Is this about right, or have I missed one/can remove more?

We can show you how to narrow it down once we have figured out what you
are trying to do.

Regards,
Tim

Mime
View raw message