harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [classlib]native tests hang up on the Linux x86_64
Date Thu, 21 Jun 2007 16:20:49 GMT

On 21 June 2007 at 21:15, "Tony Wu" <wuyuehao@gmail.com> wrote:
> On 6/21/07, Mark Hindess <mark.hindess@googlemail.com> wrote:
> >
> > It looks like commit r548949 removed the use[0] of the property
> > test.portlib which was being used to prevent the tests running on x86_64
> > because of this problem (and to prevent the tests running on windows
> > which I think is no longer an issue).
> >
> 
> Seems I should remove the condition <not><isset property="is.windows"
> /></not> rather than the use of the property.

Exactly.

> In your opinion, should we prevent these tests on SUSE?

No.  I could be wrong, but I think it more likely that the key to the
failure lies in the fact that Vladimir was using a 64bit machine than
in the fact that it was SuSE.

-Mark.

> > [0] The test.portlib define is still left behind.  If this property
> > really isn't required any more then the definition should also be
> > removed.  However it seems the property is still required.
> >
> > On 21 June 2007 at 19:15, "Tony Wu" <wuyuehao@gmail.com> wrote:
> > > hmm,it was ok on my winxp sp2 and ubuntu6, I'll take a look.
> > >
> > > On 6/21/07, Vladimir Ivanov <ivavladimir@gmail.com> wrote:
> > > > Hello,
> > > > native tests hang up on the SUSE 9 Linux x86_64. The last record in
> > > > the log file is:
> > > > "[exec] -run-native-tests:"
> > > >
> > > > After that the process "hycpu" executed at least for 45 minutes (CPU ti
> me).
> > > >
> > > > Could someone take care about this issue?
> > > >
> > > >  thanks, Vladimir
> > > >
> > > > Note, this hang happened started from yesterday.
> > > >
> > >
> > >
> > > --
> > > Tony Wu
> > > China Software Development Lab, IBM
> > >
> >
> >
> >
> 
> 
> -- 
> Tony Wu
> China Software Development Lab, IBM
> 



Mime
View raw message