harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yang Paulex" <paulex.y...@gmail.com>
Subject Re: Snapshot r533200 doesn't compatible with subclipse?
Date Thu, 10 May 2007 12:09:55 GMT
2007/5/2, Rana Dasgupta <rdasgupt@gmail.com>:
>
> Hi Paulex,
>     Do you still see this problem? On the current build, I could
> install the subclipse plugin from your URL and the Eclipse workbench
> restarted without problems. I am not very enlightened on Eclipse, so
> that is no guarantee that everything is fine now.


Yes, I still have this problem with r533200 windows build, will have a try
tomorrow on latest clean DRLVM build.

   The assert hythread_is_suspend_enabled Leo reports can happen ( I
> think ) on a less frequent codepath where loading a native library
> during startup causes an UnsatisfiedLinkError exception, but the
> creation of the exception object fails, and the suspend_enable state
> is sometimes left in an incorrect condition.
>   Anyway, if you still see the problem on the current build, could you
> please create a JIRA and we can try a patch to fix the assert. That
> would at least let us see the exception and rootcause the basic
> problem ?


Sorry I forgot  to mention before on the dev-list, a JIRA issue has been
raised several days ago here:
http://issues.apache.org/jira/browse/HARMONY-3790

Thanks,
> Rana
>
>
> On 4/30/07, Yang Paulex <paulex.yang@gmail.com> wrote:
> > 2007/4/29, Tim Ellison <t.p.ellison@gmail.com>:
> > >
> > > I'm guessing that this is not a common code path then, and we would
> not
> > > consider this a reason to delay the milestone?
> >
> >
> > I'm fine with this,  and go to raise a jira :)
> >
> > Regards,
> > > Tim
> > >
> > >
> > > Mikhail Fursov wrote:
> > > > Looks like this path was not tested for some period of time and we
> have
> > > a
> > > > regression here. Let's wait for VM gurus to point a place where to
> add
> > > > extra
> > > > suspend_enable() call.
> > > >
> > > > On 4/29/07, Leo Li <liyilei1979@gmail.com> wrote:
> > > >>
> > > >>   I use the debug build of drlvm on windows and it reports:
> > > >>
> > > >>   Assert Failed!
> > > >>   Program: .../javaw.exe
> > > >>   File: .../except...mpl.cpp  (I think is exceptions_impl.cpp)
> > > >>   Line: 262
> > > >>
> > > >>   Expression: hythread_is_suspend_enable()
> > > >>
> > > >>   ...
> > > >>
> > > >>   And the native stacktracen from debugger is :
> > > >>   harmonyvm.dll!_assert(const char * expr=0x007a121c, const char *
> > > >> filename=0x007a11d0, unsigned int lineno=262)  Line 295 C
> > > >>   harmonyvm.dll!create_exception(Class * exc_class=0x02efa100,
> const
> > > char
> > > >> *
> > > >> exc_message=0x0b647e08, _jobject * exc_cause=0x00000000)  Line 262
> +
> > > >> 0x1d C++
> > > >>   harmonyvm.dll!exn_create(Class * exc_class=0x02efa100, const char
> *
> > > >> exc_message=0x0b647e08, _jobject * exc_cause=0x00000000)  Line 175
> +
> > > 0xf
> > > >> C++
> > > >>   harmonyvm.dll!exn_create(const char * exc_name=0x007973f8, const
> char
> > > *
> > > >> exc_message=0x0b647e08, _jobject * cause=0x00000000)  Line 210 +
> 0x11
> > > C++
> > > >>   harmonyvm.dll!exn_create(const char * exc_name=0x007973f8, const
> char
> > > *
> > > >> exc_message=0x0b647e08)  Line 197 + 0xf C++
> > > >>   harmonyvm.dll!ClassLoader::ReportException(const char *
> > > >> exn_name=0x007973f8,
> > > >>
> > >
> std::basic_stringstream<char,std::char_traits<char>,std::allocator<char>
> > > >> >
> > > >> &
> > > >> message_stream={...})  Line 1778 + 0x2e C++
> > > >>   harmonyvm.dll!ClassLoader::LoadNativeLibrary(const char *
> > > >> name=0x0b647b88)  Line 951 + 0x19 C++
> > > >>   harmonyvm.dll!class_loader_load_native_lib(const char *
> > > lib=0x0b647b88,
> > > >> ClassLoader * cl=0x0b515270)  Line 90 C++
> > > >>
> > > >> harmonyvm.dll!Java_java_lang_VMClassRegistry_loadLibrary
> > > (JNIEnv_External
> > > >> *
> > > >> jenv=0x064f7ed8, _jobject * __formal=0x085cc86c, _jobject *
> > > >> filename=0x085cc870, _jobject * classLoader=0x085cc874)  Line 538
+
> 0xd
> > > >> C++
> > > >>   02c410ad()
> > > >>   harmonyvm.dll!get_vm_thread(HyThread * thr=0x085cc8a0)  Line 190
> +
> > > 0xb
> > > >> C++
> > > >>   harmonyvm.dll!get_vm_thread(HyThread * thr=0x00000001)  Line 191
> +
> > > 0x7
> > > >> C++
> > > >>   00000001()
> > > >>
> > > >>   Is there anyone familiar with the problem?
> > > >>
> > > >>
> > > >> On 4/29/07, Yang Paulex <paulex.yang@gmail.com> wrote:
> > > >> >
> > > >> > Good news is Eclipse running happily on this build(winxp sp2),
so
> I
> > > >> tried
> > > >> > to
> > > >> > install subclipse plugin and checkout Harmony trunk to workspace.
> I
> > > >> used
> > > >> > the
> > > >> > update site[1], and everything seems fine. After installation,
> > > Eclipse
> > > >> > asked
> > > >> > me if I want to restart, I clicked yes and then the Eclipse
> workbench
> > > >> > closed, when it appears again, an Windows standard error dialog
> come
> > > >> with
> > > >> > it, which shows VM launcher encountered errors and must be
> closed.
> > > The
> > > >> > .log
> > > >> > in workspace just has nothing printed out yet.  When I closed
> Eclipse
> > > >> and
> > > >> > removed the subclipse jars from eclipse/plugins directory, the
> issue
> > > >> > disappears.
> > > >> >
> > > >> > IBM VME doesn't have this problem.
> > > >> >
> > > >> > [1] http://subclipse.tigris.org/update_1.2.x
> > > >> >
> > > >> > --
> > > >> > Paulex Yang
> > > >> > China Software Development laboratory
> > > >> > IBM
> > > >> >
> > > >>
> > > >>
> > > >>
> > > >> --
> > > >> Leo Li
> > > >> China Software Development Lab, IBM
> > > >>
> > > >
> > > >
> > > >
> > >
> >
> >
> >
> > --
> > Paulex Yang
> > China Software Development laboratory
> > IBM
> >
>



-- 
Paulex Yang
China Software Development laboratory
IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message