harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Petrenko" <alexey.a.petre...@gmail.com>
Subject Re: ECJ and Harmony
Date Tue, 29 May 2007 05:40:28 GMT
2007/5/28, Alexei Zakharov <alexei.zakharov@gmail.com>:
> BTW, if I remember correctly ECJ is never called by means of "java
> -jar ecj.jar" from our build scripts. This way, the issue is only
> applicable to the situation then user wants to run ECJ manually for
> his/her personal needs. However, in this case he/she can be using any
> version of ECJ he/she likes.
But you will need to upgrade your already downloaded version to get
this patch anyway. And it does not really matter to what version to
upgrade.

So I agree that backporting is not needed.

SY, Alexey

> 2007/5/28, Gregory Shimansky <gshimansky@apache.org>:
> > Olivier Thomann wrote:
> > > "Alexei Zakharov" <alexei.zakharov@gmail.com> wrote on 2007-05-25
> > > 09:57:59:
> > >> As for "java -jar ecj.jar ..." - looks like it can be fixed only by
> > >> downloading new version of ecj.jar that includes Oliver's patch.
> > > The patch can be backported to 3.2 maintenance stream. It is pretty
> > > straight forward.
> > > If you want this, please mention it in the bug report [1].
> > >
> > > [1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=188648
> >
> > I think backporting is not needed. We're currently using ECJ 3.3M7. I
> > think as soon as 3.3RC2 will appear we'll switch URL to download it, and
> > so workaround won't be needed any more.
> >
> > --
> > Gregory
> >
> >
>
>
> --
> Alexei Zakharov,
> Intel ESSD
>

Mime
View raw message