harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Fursov" <mike.fur...@gmail.com>
Subject Re: problem under windows
Date Tue, 22 May 2007 08:00:17 GMT
On 5/18/07, Michael M. Miskulin <mmm@projectumbra.org> wrote:
>
>
> Ok, seems same result.
>
> C:\jre>run.cmd
>
> C:\jre>c:\jre\bin\java -Xem:jet -XX:em.jitPath=C:\jre\jitrino.dll Hello
> APR_DSO_LOAD: loading em.dll
> APR_DSO_LOAD: loading C:\jre\jitrino.dll
> ERROR: code:-1073741795 msg:(null)
> ERROR: code:-1073741795 msg:(null)
> Failure to open JIT dll C:\jre\jitrino.dll 720317
> apr code: The system cannot find message text for message number 0x%1 in
> the mes
> sage file for %2.
> EM: JIT library loading error:'C:\jre\jitrino.dll'
> Cannot instantiate EM
> HMYEXEL062E Internal VM error: Failed to create Java VM
> FAILED to invoke JVM.
> C:\jre>

We have unreadable error code here again and this is strange. I tried to add
errors intentionally into JIT initialization (illegal memory access) and
always have valid error codes.
Do you have any pop up dialog with debugging option? (It must appear on any
PC with MSVC installed)
If you have not, another option is to send a complete debug build to you and
check it.
?



In addition, the -Xint option fails to work now too.


I didn't check it with interpreter, so its OK (our builds are not
synchronized). The only  test I checked was Hello world application with
JIT.

-- 
Mikhail Fursov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message