harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Blewitt" <alex.blew...@gmail.com>
Subject Re: [classlib][build] win64 build can not find vmi.h when compiling libglob.c
Date Sun, 13 May 2007 08:01:15 GMT
This seems typical of a build in which the space in "C:\Documents and
Settings" is being treated as separate files, rather than a full
filename.

If you build it in a path without spaces (e.g. c:\temp\trunk) it will
probably work.

You could also try doing "cd c:\Docume~1\weldon\trunk" which would
force the shell to emulate the old 8.3 file names for that directory.
(I don't know if this would cause any other problems.)

There may be a better answer (does the FAQ have anything to offer?)
for building on Windows; however, I don't have access to a Windows box
so can't offer a better suggestion.

Alex.

On 13/05/07, Weldon Washburn <weldonwjw@gmail.com> wrote:
> Does anyone else see the following build problem?  I see vmi.h in
> ...working_classlib/deploy/include.  It seems cl.exe is ignoring the
> "/IC:Documents..." command line argument!?  Maybe I am missing some
> environment variable?
>
> Some specifics on my build environment:
>
> I am using cywin and the startup bat file looks like:
> call "C:\Program Files (x86)\Microsoft Visual Studio 8\VC\vcvarsall.bat"
> amd64
>
> D:
>
> chdir D:\cygwin\bin
>
> bash --login -i
> ant -version shows:
> Apache Ant version 1.6.5 compiled on June 2 2005
>
> ----------------------------------- A cut/paste from the cygwin build window
> on the win64 box -----------------------
>
> -build-native:
>      [exec]     cl -c -DCRTAPI1=_cdecl -DCRTAPI2=_cdecl -nologo -GS -
> FIsehmap.h
> -D_AMD64_=1 -DWIN64 -D_WIN64  -DWIN32 -D_WIN32 /FIPRE64PRA.H -Wp64 -W4
> -D_WIN95
> -D_WIN32_WINDOWS=0x0400 /D_WIN32_DCOM -D_WIN32_IE=0x0500 -DWINVER=0x0400 -Zi
> -Od
>  -W0 -GF -Gs -MD -Zm400  -D_DLL -D_MT -D_WINSOCKAPI_ -DHYX86_64
> /IC:\Documents
> and Settings\weldon\trunk\working_classlib\deploy\include /IC:\Documents and
> Set
> tings\weldon\trunk\working_classlib\deploy\jdk\include /I. /I..\shared\
> -Fo..\sh
> ared\libglob.obj ..\shared\libglob.c
>      [exec] cl : Command line warning D9025 : overriding '/W4' with '/W0'
>      [exec] cl : Command line warning D9024 : unrecognized source file type
> 'and
> ', object file assumed
>      [exec] cl : Command line warning D9027 : source file 'and' ignored
>      [exec] cl : Command line warning D9024 : unrecognized source file type
> 'Set
> tings\weldon\trunk\working_classlib\deploy\include', object file assumed
>      [exec] libglob.c
>      [exec] cl : Command line warning D9027 : source file
> 'Settings\weldon\trunk
> \working_classlib\deploy\include' ignored
>      [exec] cl : Command line warning D9024 : unrecognized source file type
> 'and
> ', object file assumed
>      [exec] cl : Command line warning D9027 : source file 'and' ignored
>      [exec] cl : Command line warning D9024 : unrecognized source file type
> 'Set
> tings\weldon\trunk\working_classlib\deploy\jdk\include', object file assumed
>      [exec] cl : Command line warning D9027 : source file
> 'Settings\weldon\trunk
> \working_classlib\deploy\jdk\include' ignored
>      [exec] ..\shared\libglob.c(25) : fatal error C1083: Cannot open include
> fil
> e: 'vmi.h': No such file or directory
>      [exec] NMAKE : fatal error U1077: '"c:\Program Files (x86)\Microsoft
> Visual
>  Studio 8\VC\BIN\amd64\cl.EXE"' : return code '0x2'
>      [exec] Stop.
>
> BUILD FAILED
>
>
> --
> Weldon Washburn
>

Mime
View raw message