harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: problem under windows
Date Sat, 12 May 2007 14:20:05 GMT
Michael M. Miskulin wrote:
> Tried the irc but room was empty and there doesn't appear to be another
> forum for such questions.  If there is, please point me to it.

You are in the right place!

> Installed the windows version

Which build specifically?  Did you download a pre-built binary or build
it from source yourself?  What version of Windows are you using (i.e.
2000/XP/Vista/...)?

> and set the path and home variables.
> Yet am receiving a message:
> 
> Failure to open JIT dll C:\jre\bin/default/\jitrino.dll -1073021795
> apr code: Unknown error
> EM: JIT library loading error:'C:\jre\bin/default/\jitrino.dll'
> Cannot instantiate EM
> HMYEXEL062E Internal VM error: Failed to create Java VM
> FAILED to invoke JVM.
> 
> The dll exists and is in C:\jre\bin\default  
> 
> Is this an issue with the "\" vs "/" ?   I found one short
> thread with a similar problem but there was no resolution.
> Is there something else I must do or install?

In principle there is nothing more you should need to do.  It is
possible it is a missing dependency that is causing the JIT DLL load to
fail (rather than that DLL not being found).

If that is the problem we can help figure it out using a number of tools
that show DLL dependencies, some of those tools are listed here
http://msdn.microsoft.com/msdnmag/issues/02/06/debug/

> Thanks for any assistance or redirection to other resource.

Let us know how you get on.

Regards,
Tim

Mime
View raw message