harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yang Paulex" <paulex.y...@gmail.com>
Subject Re: [snapshot] Missing debug info in class files
Date Sat, 28 Apr 2007 17:59:28 GMT
2007/4/29, Yang Paulex <paulex.yang@gmail.com>:
>
>
>
> 2007/4/29, Tim Ellison <t.p.ellison@gmail.com>:
> >
> > Tim Ellison wrote:
> > > Yang Paulex wrote:
> > >> Seems there's an issue of r533200(i.e. the M1 download) for windows,
> > >> kernel.jar is not included in the bootclasspath, so that the compiler
> > >> complain java.lang.Object cannot be resolved in Eclipse, anyone saw
> > this
> > >> issue?
> > >
> > > I'm confused, if kernel.jar was not in the bootclasspath then nothing
> > > would run.
> > >
> > > Do you mean our javac wrapper in the JDK doesn't pick it up?
> >
> >
> > Oh, maybe I know what you mean ... the Eclipse plug-in support doesn't
> > pick up the kernel JARs.  That's a simple update to the vm properties
> > file -- and very safe (the VM and class library don't read them).
>
>
> I noticed the harmonyvm.properties has been updated with three jars
> directory added, but after copying them into r533200 build and reinstall it
> as Eclipse JRE, the three kernel jars still didn't been loaded, anything I
> missed?
>

Seems %VM_DIR%  isn't parsed correctly, changing it to "default" fixes the
issue, but I guess it is not preferred to hard code it. Any ideas what
prevenrts %VM_DIR% being recognized by Eclipse plugin?

Regards,
> > Tim
> >
>
>
>
> --
> Paulex Yang
> China Software Development laboratory
> IBM
>



-- 
Paulex Yang
China Software Development laboratory
IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message