harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Popov" <ivan.g.po...@gmail.com>
Subject Re: Harmony+Eclipse and Scrapbook Pages
Date Fri, 20 Apr 2007 13:37:07 GMT
I traced debug events sent from Harmony to Eclipse and see that it
sends both BREAKPOINT and STEP events. However, the first STEP event
is generated for method java.lang.NoClassDefFoundError.<init>. It
seems that Eclipse ignores such STEP event, resumes execution and hits
breakpoint again.

I think the problem is that Harmony cannot find particular class while
execution code generated for Scrapbook snippet. Is it possible to look
at the generated code to understand what is the problem with class
loading?

Thanks.
Ivan

On 4/20/07, Ivan Popov <ivan.g.popov@gmail.com> wrote:
> I reproduced this problem and I'm investigating now what events are
> generated by Harmony in this case.
>
> Ivan.
>
> On 4/20/07, Tim Ellison <t.p.ellison@gmail.com> wrote:
> > Ivan Popov wrote:
> > > This differs from other JRE, but I don't think it caused those
> > > problems with Scrapbook.
> >
> > Both are hitting the breakpoint, then when stepping over, the IBM/Sun
> > VMs seem to be producing:
> >
> > DebugEvent[..., RESUME, STEP_RETURN]
> > DebugEvent[..., SUSPEND, STEP_END]
> >
> > On DRLVM I see the STEP_RETURN but I don't see the STEP_END event, which
> > is described in the Eclipse code as "Indicates a thread was suspended
> > due to the completion of a step action"
> >
> > Eclipse is looking for that STEP_END event.
> >
> > Tim
> >
>

Mime
View raw message