harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Qi Ji" <kent...@gmail.com>
Subject Re: [drlvm] Problem of running ehwa.test
Date Mon, 23 Apr 2007 07:20:51 GMT
I run ehwa.test with both GCv5 and GCv4.1.
GCv5 can pass the jitrino and interpreter mode test, GCv4.1 can pass the
jitrino mode test and failed the other two modes with the same exception as
below.

Thanks!

On 4/23/07, Qi Ji <kent.qi@gmail.com> wrote:
>
> Hi, folks,
>   I run ehwa.test, which is a test of eclipse helloworld senario, on Win32
> platform with the latest svn like this:
> c:\working\directory> build.bat ehwa.test
> and got the following output infomation at jit mode:
>
>      [echo]
>      [echo]         ==================================
>      [echo]         Run Eclipse HelloWorld using Client mode JIT (default)
>      [echo]         ==================================
>      [echo]
>      [java] Testsuite: HelloAuto.CreateAndRunTest
>      [java] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 51.063 sec
>
>      [java] Testcase: testHi took 50.953 sec
>      [java]     FAILED
>      [java] timed out
>      [java] junit.framework.AssertionFailedError: timed out
>      [java]     at HelloAuto.CreateAndRunTest.testHi(CreateAndRunTest.java:86)
>      [java]     at java.lang.reflect.VMReflection.invokeMethod(
> VMReflection.java)
>      [java]     at org.eclipse.test.EclipseTestRunner.run(
> EclipseTestRunner.java:313)
>      [java]     at org.eclipse.test.EclipseTestRunner.run (
> EclipseTestRunner.java:199)
>      [java]     at org.eclipse.test.UITestApplication$3.run(
> UITestApplication.java:188)
>      [java]     at org.eclipse.swt.widgets.RunnableLock.run(
> RunnableLock.java:35)
>      [java]     at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
> Synchronizer.java:123)
>      [java]     at org.eclipse.swt.widgets.Display.runAsyncMessages(
> Display.java:3057)
>      [java]     at org.eclipse.swt.widgets.Display.readAndDispatch (
> Display.java:2716)
>      [java]     at org.eclipse.ui.internal.Workbench.runEventLoop(
> Workbench.java:1699)
>      [java]     at org.eclipse.ui.internal.Workbench.runUI(Workbench.java
> :1663)
>      [java]     at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
> Workbench.java:367)
>      [java]     at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
> PlatformUI.java:143)
>      [java]     at org.eclipse.ui.internal.ide.IDEApplication.run(
> IDEApplication.java:103)
>      [java]     at org.eclipse.test.UITestApplication.runApplication(
> UITestApplication.java:131)
>      [java]     at org.eclipse.test.UITestApplication.run(
> UITestApplication.java:58)
>      [java]     at
> org.eclipse.core.internal.runtime.PlatformActivator$1.run (
> PlatformActivator.java:226)
>      [java]     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(
> EclipseStarter.java:376)
>      [java]     at org.eclipse.core.runtime.adaptor.EclipseStarter.run(
> EclipseStarter.java :163)
>      [java]     at java.lang.reflect.VMReflection.invokeMethod(
> VMReflection.java)
>      [java]     at org.eclipse.core.launcher.Main.invokeFramework(
> Main.java:334)
>      [java]     at org.eclipse.core.launcher.Main.basicRun (Main.java:278)
>      [java]     at org.eclipse.core.launcher.Main.run(Main.java:973)
>      [java]     at org.eclipse.core.launcher.Main.main(Main.java:948)
>      [java]     at java.lang.reflect.VMReflection.invokeMethod (
> VMReflection.java)
>      [java]     at org.apache.harmony.vm.JarRunner.main(JarRunner.java:80)
>
>      [java] Java Result: 1
>
>   I also run it directly by command:
>
> C:\harmony-2007.03.26\trunk\working_vm_2007.04.20\build>
>
> C:\harmony-
> 2007.03.26\trunk\working_vm_2007.04.20\build\win_ia32_msvc_debug\deploy\jdk\jre\bin\java.exe-XX:-
> vm.assert_dialog -XX:vm.dlls=gc_cc.dll -jar C:\Kent\Software\eclipse-
> SDK-3.1.1-win32\eclipse\startup.jar -application
> org.eclipse.test.uitestapplication -dev bin -data C:\harmony-
> 2007.03.26\trunk\working_vm_2007.04.20\build\win_ia32_msvc_debug\semis\ehwa\wkspformatter=
> org.apache.tools.ant.taskdefs.optional.junit.PlainJUnitResultFormatter-testPluginName
HelloAuto -className
> HelloAuto.CreateAndRunTest
>
>   And got the same output.
>
>   Have anybody met such problem before? Discussions are welcomed :)
>
>
>
> Thanks,
>
> Qi Ji
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message