harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stepan Mishura" <stepan.mish...@gmail.com>
Subject Re: [buildtest] Proposal for Build Test Infrastructure Improvement
Date Fri, 20 Apr 2007 08:48:45 GMT
On 4/20/07, Stepan Mishura wrote:
> On 4/18/07, Alexander Kleymenov wrote:
> > I did not look at the 'Jetty Scenario' integration scripts yet.
> > So I see they have an issue.
> > Adaptor's run target should <fail if="test suite failed">.
> > Alexey, please, fix your adaptor.
> > Stepan, please, use another Test Suite.
> > I can suggest to use 'Struts Scenario' published at HARMONY-3597 JIRA issue.
>
> I've tried to setup this suite and the result is the same - the
> suite's setup failed but overall setup passed. Here is my output:
> ...
> -generate-test-data:
>    [junit] Running org.apache.harmony.struts.test.WebAppTest
>    [junit] ----URL 10000.URL./struts2-showcase-2.0.6/showcase.jsp:
> testing  with file520468537.html
>    [junit] +---Page Apache Tomcat/5.0.30 - Error report: testing
> 10010.ANCHOR.3 with file1722219095.html
>    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 1.524 sec
>    [junit] Test org.apache.harmony.struts.test.WebAppTest FAILED
>
> -stop-server-for-setup:
>
> setup:
>   [delete] Deleting: /export/users/smishura/newinfra/build/temp/null1434408292
>
> check-status:
>
> setup:
>
> BUILD SUCCESSFUL
> Total time: 18 seconds
>

Alexander,

I've tried another suite - Dacapo benchmark from [1] to test the new
infra. According to its parameters.xml it doesn't depends on drlvm but
requires property "${drlvm.parameters.shared.jre.dir}" to be set. But
I don't see any errors messages about it during running setup. Is this
a mistake?

Also the framework failed to set up it with the following error:
setup:
    [mkdir] Created dir: /export/users/smishura/newinfra/build/results/dacapo
    [mkdir] Created dir: /export/users/smishura/newinfra/build/checkouts/dacapo

-dacapo.download:
     [echo]
     [echo] --------
     [echo] WARNING: Target setup of adaptor for Test Suite 'dacapo' FAILED
     [echo] -------- with the following exception:
     [echo] The following error occurred while executing this line:
     [echo] /export/users/smishura/newinfra/adaptors/dacapo/adaptor.xml:35:
The specified destination is a directory
   [delete] Deleting: /export/users/smishura/newinfra/build/temp/null842216362

check-status:
     [echo]
     [echo] ------
     [echo] ERROR: Setup of Test Suite 'dacapo' FAILED.
     [echo] ------

BUILD FAILED
/export/users/smishura/newinfra/scripts/framework.xml:443: The
following error occurred while executing this line:
/export/users/smishura/newinfra/scripts/framework.xml:761: There are
Test Suites failures

Total time: 1 second

>From the first glance it looks like there is a mistake in Dacapo
adaptor - it failed to download some resource file. So the question is
why the suite doesn't use the framework functionality to download the
required file?

[1] https://issues.apache.org/jira/browse/HARMONY-3681

Thanks,
Stepan Mishura
Intel Enterprise Solutions Software Division

Mime
View raw message