harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Beliaev" <vladimir.k.beli...@gmail.com>
Subject Re: Problem when building harmony on 64bit Windows
Date Mon, 02 Apr 2007 12:53:28 GMT
Qi Ji,

is the any news on updated 'drlvm' build?

Your build environment seems to be ok... It has some duplications in
INCLUDE, LIB, PATH which sould not affect the build.

Also my FrameworkSDKDir points to
   C:\Program Files (x86)\Microsoft Visual Studio 8\SDK\v2.0 64bit
and your one to
   C:\Program Files (x86)\v2.0 64bit
(I think it does not affect the process...)

Thanks
VB

2007/4/2, Qi Ji <kent.qi@gmail.com>:
>
> Hi, Vladimir
> I got the newest vm and classlib from svn yesterday, and I think  that
> would
> be ok. But I'm still trying to get my drlvm updated now, and here is my
> environment settings:
>
> E:\jqi2\harmony-2007.03.31\trunk\working_vm\build>echo %INCLUDE%
> C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\ATLMFC\INCLUDE;C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\INCLUDE;C:\Program Fi
> les (x86)\Microsoft Visual Studio 8\VC\PlatformSDK\include;C:\Program
> Files
> (x86)\Microsoft Visual Studio 8\SDK\v2.0\include;C:\Program File
> s (x86)\v2.0\include;C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\ATLMFC\INCLUDE;C:\Program Files (x86)\MicrosoftVisual Studio 8\VC\I
> NCLUDE;C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\PlatformSDK\include;C:\Program Files (x86)\Microsoft Visual Studio
> 8\SDK\v2.0\inc
> lude;C:\Program Files (x86)\Microsoft Visual Studio .NET
> 2003\SDK\v1.1\include\
>
> E:\jqi2\harmony-2007.03.31\trunk\working_vm\build>echo %LIB%
> C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\ATLMFC\LIB\amd64;C:\Program Files (x86)\Microsoft Visual Studio
> 8\VC\LIB\amd64;C:\Progra
> m Files (x86)\Microsoft Visual Studio
> 8\VC\PlatformSDK\lib\amd64;C:\Program
> Files (x86)\Microsoft Visual Studio 8\SDK\v2.0\LIB\AMD64;C:\Prog
> ram Files (x86)\v2.0\Lib;C:\Program Files (x86)\v2.0\Lib\AMD64;C:\Program
> Files (x86)\Microsoft Visual Studio 8\VC\ATLMFC\LIB\amd64;C:\Progr
> am Files (x86)\Microsoft Visual Studio 8\VC\LIB\amd64;C:\Program Files
> (x86)\Microsoft Visual Studio 8\VC\PlatformSDK\lib\amd64;C:\Program F
> iles (x86)\Microsoft Visual Studio 8\SDK\v2.0\LIB\AMD64;C:\Program Files
> (x86)\Microsoft Visual Studio .NET 2003\SDK\v1.1\Lib\
>
> E:\jqi2\harmony-2007.03.31\trunk\working_vm\build>echo %LIBPATH%
> C:\Program Files (x86)\Microsoft Visual Studio 8\VC\ATLMFC\LIB\amd64;
>
> E:\jqi2\harmony-2007.03.31\trunk\working_vm\build>echo %Path%
> C:\Program Files (x86)\Microsoft Visual Studio 8\VC\BIN\amd64;C:\Program
> Files (x86)\Microsoft Visual Studio 8\VC\PlatformSDK\bin\win64\amd6
> 4;C:\Program Files (x86)\Microsoft Visual Studio
>
> 8\VC\PlatformSDK\bin;C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727;C:\Program
> Files (x86)
> \Microsoft Visual Studio 8\VC\VCPackages;C:\Program Files (x86)\Microsoft
> Visual Studio 8\Common7\IDE;C:\Program Files (x86)\Microsoft Visua
> l Studio 8\Common7\Tools;C:\Program Files (x86)\Microsoft Visual Studio
> 8\Common7\Tools\bin;C:\Program Files (x86)\Microsoft Visual Studio 8
> \SDK\v2.0\bin;C:\Program Files (x86)\Intel\VTune\CGGlbCache;C:\Program
> Files
> (x86)\Intel\VTune\Analyzer\Bin32e;C:\Program Files (x86)\Intel\
> VTune\Shared\Bin32e;C:\Program Files
> (x86)\Intel\VTune\Shared\Bin;C:\Program
> Files (x86)\Common Files\Intel\Shared Files\IDVC;C:\Program Fil
> es
> (x86)\Intel\VTune\Analyzer\Bin;c:\progra~2\java\jdk1.5.0_07\bin;C:\Program
> Files (x86)\Windows Resource Kits\Tools\;C:\Program Files\Supp
> ort
> Tools\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Program
> Files (x86)\Subversion\bin;C:\PROGRA~2\F-Secure\ssh;C:\apache-
> ant-1.6.5\bin;C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\
>
> E:\jqi2\harmony-2007.03.31\trunk\working_vm\build>echo %FrameworkSDKDir%
> C:\Program Files (x86)\v2.0 64bit
>
>
> On 4/2/07, Vladimir Beliaev <vladimir.k.beliaev@gmail.com> wrote:
> > > Could you also set your environments settings cmd ("Visual Studio 2005
> x64
> > Win64 Command Prompt"):
> >
> > I meant "Could you also send...".
> >
> >
> > 2007/4/2, Vladimir Beliaev <vladimir.k.beliaev@gmail.com>:
> > >
> > > May be it worth getting a fresh Harmony version (although it takes
> time)
> &
> > > retry with it before reinstalling windows...
> > >
> > > Another variant is to redo "update" (in properly set environment) [I
> do
> it
> > > from cygwin]:
> > > cd <trunk>/working_vm/build
> > > ./buid.bat clean
> > > rm -fr ./pre-copied
> > > rm -fr ./win_em64t_msvc_debug
> > > cd .. # the target dir is <trunk>/working_vm
> > > svn update
> > > cd ./build
> > > ./build.bat update
> > >
> > > and then try to build again...
> > >
> > > I'm recalling my situation from previous week when I was not able to
> build
> > > drlvm "kernel classes" - sources update, cleaning did not help (I
> missed
> to
> > > do "./build.update")... I did not meat previously the linking error
> you
> > > described to give the quick answer.
> > >
> > > Could you also set your environments settings cmd ("Visual Studio 2005
> x64
> > > Win64 Command Prompt"):
> > >   INCLUDE
> > >   LIB
> > >   LIBPATH
> > >   Path
> > >   FrameworkSDKDir
> > >
> > > Thanks
> > > Vladimir  Beliaev
> > >
> > > 2007/4/2, Qi Ji <kent.qi@gmail.com>:
> > > >
> > > > Vladimir, your infomation is very important to me, thank you!!
> > > > I followed Xiao-Feng's guild, and my environment virables are all
> the
> > > > same as yours, but the error is still there.
> > > > I reinstalled vs2005, but the situation was just as it was.
> > > > Could it help if I reinstall Windows?
> > > >
> > > > On 4/2/07, Vladimir Beliaev < vladimir.k.beliaev@gmail.com> wrote:
> > > > > You may call to MSVC2005 development environment setting script
> w/o
> > > > setting
> > > > > INCLUDE & LIB manually for building on windows/x86_64.
> > > > >
> > > > > You either do this with the command (if MSVC is installed to its
> > > > default
> > > > > location):
> > > > >
> > > > >   call "C:\Program Files (x86)\Microsoft Visual Studio
> > > > 8\VC\vcvarsall.bat"
> > > > > amd64
> > > > >
> > > > > or run cmd.exe through GUI from Start menu like:
> > > > >
> > > > > Start->Programs->Miscrisoft Visula Strudion 2005->Visula
Studio
> > > > > Tools->Visual Studio 2005 x64 Win64 Command Prompt
> > > > >
> > > > > Anyway, in this console (in shell):
> > > > >
> > > > > $ echo $INCLUDE
> > > > > C:\Program Files (x86)\Microsoft Visual Studio
> > > > > 8\VC\ATLMFC\INCLUDE;C:\Program Files (x86)\Microsoft Visual Studio
> > > > > 8\VC\INCLUDE;C:\Program Files (x86)\Microsoft Visual Studio
> > > > > 8\VC\PlatformSDK\include;C:\Program Files (x86)\Microsoft Visual
> > > > Studio
> > > > > 8\SDK\v2.0\include;
> > > > >
> > > > > $ echo $LIB
> > > > > C:\Program Files (x86)\Microsoft Visual Studio
> > > > > 8\VC\ATLMFC\LIB\amd64;C:\Program Files (x86)\Microsoft Visual
> Studio
> > > > > 8\VC\LIB\amd64;C:\Program Files (x86)\Microsoft Visual Studio
> > > > > 8\VC\PlatformSDK\lib\amd64;C:\Program Files (x86)\Microsoft Visual
> > > > Studio
> > > > > 8\SDK\v2.0\LIB\AMD64;
> > > > > mstmrtd193: ~ $
> > > > >
> > > > > More hints are given by Xiao-Feng here:
> > > > > http://wiki.apache.org/harmony/DevBuild_Win64
> > > > >
> > > > > Thanks
> > > > > Vladimir Beliaev
> > > > >
> > > > > 2007/4/1, Qi Ji <kent.qi@gmail.com>:
> > > > > >
> > > > > > Weldon, thanks a lot for your reply.
> > > > > > I updated classlib and drlvm, and then rebuild, but the error
> still
> > > > exist.
> > > > > > Can anybody paste here the win64 environment virables, such
as
> > > > INCLUDE and
> > > > > > LIB?
> > > > > >
> > > > > > Thanks!
> > > > > > Qi Ji
> > > > > >
> > > > > > On 3/30/07, Weldon Washburn < weldonwjw@gmail.com> wrote:
> > > > > > > Sorry for the inconvenience.  Please try "svn update" now.
 We
> > > > have had
> > > > > > a
> > > > > > > very difficult time applying a performance enhancement
that
> > > > inlines
> > > > > > > thread-local storage (H3065).  It should be fixed now.
> > > > > > >
> > > > > > > On 3/29/07, kent qi <kent.qi@gmail.com> wrote:
> > > > > > > >
> > > > > > > > Hi, colleagues,
> > > > > > > >    When building harmony on 64bit Windows, I met such
> problem:
> > > > > > > >
> > > > > > > > build.native.link:
> > > > > > > >       [cc] 0 total files to be compiled.
> > > > > > > >       [cc] Starting link
> > > > > > > >       [cc]    Creating library jitrino.lib and object
> > > > jitrino.exp
> > > > > > > >       [cc] LINK : error LNK2001: unresolved external
symbol
> > > > > > _CorDllMain
> > > > > > > >       [cc] jitrino.dll : fatal error LNK1120: 1 unresolved
> > > > externals
> > > > > > > >
> > > > > > > >
> > > > > > > >    Does anyone know how to fix it? Thanks a lot!!
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Weldon Washburn
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Vladimir Beliaev
> > > > > Intel Middleware Products Division
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Vladimir Beliaev
> > > Intel Middleware Products Division
> > >
> >
> >
> >
> > --
> > Vladimir Beliaev
> > Intel Middleware Products Division
> >
>



-- 
Vladimir Beliaev
Intel Middleware Products Division

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message