harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer" <ndbe...@apache.org>
Subject Re: [build] need help building harmony on windows
Date Fri, 27 Apr 2007 03:20:10 GMT
On 4/26/07, Naveen Neelakantam <neelakan@uiuc.edu> wrote:
>
> On Apr 26, 2007, at 9:31 AM, Gregory Shimansky wrote:
>
> > Naveen Neelakantam wrote:
> >> I rebuilt using r532300 and did a "build clean" first (both
> >> classlib and vm), but I am seeing the same error.  It occurs even
> >> when I just try -showversion:
> >> D:\neelakan\trunk\working_vm\build\win_ia32_msvc_debug\deploy\jdk
> >> \jre\bin>java -showversion
> >> Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache
> >> Software Foundation or its licensors, as applicable.
> >> java version "1.5.0"
> >> pre-alpha : not complete or compatible
> >> svn = r532300, (Apr 26 2007), Windows/ia32/msvc 1310, debug build
> >> http://incubator.apache.org/harmony
> >> Failure to open JIT dll D:\neelakan\trunk\working_vm\build
> >> \win_ia32_msvc_debug\deploy\jdk\jre\bin/default/\jitrino.dll
> >> -1073021795
> >
> > I assume you've checked that jitrino.dll actually exists in this
> > directory. Now it is possible that it cannot load some dependency
> > DLLs. There is a depends.exe command in MSVC where you can open DLL
> > and try to see which DLLs linked with jitrino.dll it cannot find.
>
> I ran depends.exe on jitrino.dll and it says that it cannot find
> icuu34.dll and dwmapi.dll.  How do I get these dll's?

By default, depends.exe won't be looking at the all of the appropriate
folders, so it will seem like many DLLs are missing. You'll need to
include both "jre/bin" and "jre/bin/default" in the module load path
to properly simulate what the launcher sets up.

-Nathan

>
> >
> >> apr code: Unknown error
> >> EM: JIT library loading error:'D:\neelakan\trunk\working_vm\build
> >> \win_ia32_msvc_debug\deploy\jdk\jre\bin/default/\jitrino.dll' And
> >> the following abort message pops up (screen grab):
> >> http://freya.cs.uiuc.edu/~neelakan/abort_message.tiff
> >
> > This error message is caused by a bug in EM. It tries to free some
> > unallocated pointer when it gets an error loading jitrino.dll.
> >
> >> On Apr 26, 2007, at 12:54 AM, Pavel Ozhdikhin wrote:
> >>> Naveen,
> >>>
> >>> That's how I build on Windows (actual host names and ports are
> >>> removed):
> >>>
> >>> # Set environment
> >>> set PATH=c:\jrockit-jdk1.5.0\bin;c:\utils\apache-ant-1.6.5\bin;%
> >>> PATH%
> >>> set JAVA_HOME=c:\jrockit-jdk1.5.0
> >>> set ANT_HOME=c:\utils\apache-ant-1.6.5
> >>> set ANT_OPTS=-Dhttp.proxyHost=proxy_host -Dhttp.proxyPort=proxy_port
> >>>
> >>> # Checkout
> >>> svn co https://svn.apache.org/repos/asf/harmony/enhanced/trunk
> >>> cd trunk
> >>> ant populate_source
> >>>
> >>> # Build classlib
> >>> cd working_classlib
> >>> ant fetch-depends
> >>> ant
> >>>
> >>> # Build DRLVM
> >>> set CXX=msvc
> >>> set BUILD_CFG=debug
> >>> build.bat update
> >>> build.bat
> >>>
> >>> Quite the same as on Linux and it worked fine for me. Please make
> >>> sure
> >>> your do 'build clean' after doing 'svn update' - in many cases
> >>> partial
> >>> rebuild did not work for me.
> >>>
> >>> Thanks,
> >>> Pavel
> >>>
> >>> On 4/26/07, Naveen Neelakantam <neelakan@uiuc.edu> wrote:
> >>>> I'll try rolling back and see what happens.
> >>>>
> >>>> On Apr 25, 2007, at 10:37 PM, Vladimir Ivanov wrote:
> >>>>
> >>>> > You can use r532300 for tests (r532301 was updated to show this
> >>>> > message as 'usage help').
> >>>> > That is for jitrino question I never saw it. I think, we
> >>>> should wait
> >>>> > our jit guys...
> >>>> >
> >>>> > thanks, Vladimir
> >>>> >
> >>>> >
> >>>> > On 4/26/07, Naveen Neelakantam <neelakan@uiuc.edu> wrote:
> >>>> >> I forgot to mention that I followed the directions on http://
> >>>> >> harmony.apache.org/quickhelp_contributors.html
> >>>> >>
> >>>> >> On Apr 25, 2007, at 10:09 PM, Naveen Neelakantam wrote:
> >>>> >>
> >>>> >> > I am trying to get a windows development environment setup
> >>>> to track
> >>>> >> > down a bug (HARMONY-1788), but I'm having trouble.
> >>>> >> >
> >>>> >> > I managed to build the classlib and drlvm on Windows 2003
> >>>> using
> >>>> >> > Visual Studio .NET 2003 and the eclipse JDK, but whenever
I
> >>>> try to
> >>>> >> > run the vm, I see the following:
> >>>> >> >
> >>>> >> > D:\neelakan\trunk\working_vm\build\win_ia32_msvc_debug
> >>>> \deploy\jdk
> >>>> >> > \jre\bin>java
> >>>> >> > Harmony Java launcher
> >>>> >> > Apache Harmony Launcher : (c) Copyright 1991, 2006 The
Apache
> >>>> >> > Software Foundation or its licensors, as applicable.
> >>>> >> > java [-vm:vmdll -vmdir:dir -D... [-X...]] [args]
> >>>> >> >
> >>>> >> > Help?  I'm totally clueless on Windows...
> >>>> >> >
> >>>> >> > Naveen
> >>>> >>
> >>>> >>
> >>>>
> >>>>
> >
> >
> > --
> > Gregory
> >
>
>

Mime
View raw message