harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer" <ndbe...@apache.org>
Subject Re: [classlib][testing] the test org.apache.harmony.luni.tests.java.lang.ProcessBuilderTest failed today
Date Thu, 26 Apr 2007 03:57:02 GMT
On 4/25/07, Vladimir Ivanov <ivavladimir@gmail.com> wrote:
> On 4/26/07, Stepan Mishura <stepan.mishura@gmail.com> wrote:
> > On 4/26/07, Vladimir Ivanov wrote:
> > > Command 'java -version' does not work now on DRLVM:
> > >
> > > trunk> build/lnx_em64t_gcc_debug/deploy/jdk/jre/bin/java -version
> > > Harmony Java launcher
> > > Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software
> > > Foundation or its licensors, as applicable.
> > > java [-vm:vmdll -vmdir:dir -D... [-X...]] [args]
> > > trunk>
> > >
> >
>
> > Now DRL VM prints help message instead of version info. See commit r532301:
> >
> > Patch for HARMONY-3615 "[classlib][launcher] should print help message
> > when run without class specified"
>
> Thanks for your investigation.
> trunk> build/lnx_em64t_gcc_debug/deploy/jdk/jre/bin/java -version; echo $?
> Harmony Java launcher
> Apache Harmony Launcher : (c) Copyright 1991, 2006 The Apache Software
> Foundation or its licensors, as applicable.
> java [-vm:vmdll -vmdir:dir -D... [-X...]] [args]
> 1
> trunk>
>
> Actually, I expect output similar to '-help' option. And I believe
> '-version' should finished with zero return code.
> Should we revert patch or wait for fix?

I guess it depends if this is considered an error. Shouldn't a version
number be shown? Does this mean that the VM library didn't load?

The RI returns 0, but it also returns the version number.

$ java -version; echo $?
java version "1.6.0"
Java(TM) SE Runtime Environment (build 1.6.0-b105)
Java HotSpot(TM) Server VM (build 1.6.0-b105, mixed mode)
0

-Nathan

>
> thanks, Vladimir
>
> >
> > Thanks,
> > Stepan.
> >
> > >  thanks, Vladimir
> > >
> > > On 4/26/07, Vladimir Ivanov <ivavladimir@gmail.com> wrote:
> > > > The CC/CI systems report failure of the
> > > > org.apache.harmony.luni.tests.java.lang.ProcessBuilderTest on Win/Lnx
> > > > boxes with message:
> > > > Test: testStartClass:
> > > > org.apache.harmony.luni.tests.java.lang.ProcessBuilderTestjunit.framework.AssertionFailedError
> > > >        at org.apache.harmony.luni.tests.java.lang.ProcessBuilderTest.testStart(ProcessBuilderTest.java:161)
> > > >        at java.lang.reflect.VMReflection.invokeMethod(VMReflection.java)
> > > >
> > > > Could someone reproduce/take care about this issue?
> > > >
> > > >  thanks, Vladimir
> > > >
> > >
> >
> >
> > --
> > Stepan Mishura
> > Intel Enterprise Solutions Software Division
> >
>

Mime
View raw message