harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sian January" <sianjanu...@googlemail.com>
Subject Re: [general] Can't launch Harmony
Date Fri, 23 Mar 2007 14:23:21 GMT
Just as a quick update, I am able to successfully run the Harmony JDK as
downloaded from the website (with the IBM VME and with DRLVM), but just not
the one I build myself.  Not sure if this sheds any light on the problem at
all.  Is it possible that the build process is finding the wrong version of
a dll or something?

Thanks again,

Sian


On 21/03/07, Sian January <sianjanuary@googlemail.com> wrote:
>
> Hi Gregory and Alexey,
>
> Thank you both for your help.  I ran the static analysis in Dependency
> Walker, but there doesn't seem to be anything wrong there.  I then ran it
> dynamically and I think that's where the problem is occurring, but I'm not
> really sure how to interpret the results.  The end of the log looks like
> this:
>
> * Second chance exception 0xC0000005 (Access Violation) occurred in "
> HYPRT.DLL" at address 0x111049B3.
> *Exited "JAVA.EXE" (process 0x14EC) with code -1073741819 (0xC0000005). **
>
> If anyone would like to have a look at the whole log I could send it
> individually, but I didn't want to send it to the whole list as it's about
> 900K.
>
> Thanks,
>
> Sian
>
>
>  On 21/03/07, Alexey Petrenko <alexey.a.petrenko@gmail.com> wrote:
> >
> > Dependency walking tool can be found here: http://www.dependencywalker.com/
> >
> >
> > SY, Alexey
> >
> > 2007/3/20, Gregory Shimansky <gshimansky@gmail.com>:
> > > Sian January wrote:
> > > > Hello,
> > > >
> > > > I'm having major problems trying to run anything at all with
> > Harmony.  The
> > > > launcher won't run at all and I just get a pop-up box saying "VM
> > launcher
> > > > has encountered a problem and needs to close. We are sorry for the
> > > > inconvenience."  I'm running on Windows XP with the IBM v4 VME and
> > the
> > > > latest class library build that I built myself.  I've tried a
> > complete
> > > > clean
> > > > and rebuild and I'm still seeing the same problem.  Has anyone seen
> > this
> > > > before?
> > >
> > > It is likely a missing DLL dependency to the java.exe launcher. I
> > > haven't seen it before. There is a DLL dependency analyzer tool in
> > MSVC
> > > called "depends". You can try to open java.exe launcher with it and
> > try
> > > to understand which DLL that is necessary to it is absent.
> > >
> > > --
> > > Gregory
> > >
> > >
> >
>
>
>
> --
> Unless stated otherwise above:
> IBM United Kingdom Limited - Registered in England and Wales with number
> 741598.
> Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU
>
>



-- 
Unless stated otherwise above:
IBM United Kingdom Limited - Registered in England and Wales with number
741598.
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message