harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Ivanov" <ivavladi...@gmail.com>
Subject [general][testing] run of classlib tests on overloaded box
Date Tue, 20 Mar 2007 09:26:12 GMT
Hi,
in order to look at CC failure notification (issue 3437) the CLASSLIB
tests were run in the 'stress' environment. Seems, we have a big
problem here. On the 'awt' module I already saw some output like:
<...>
    [junit] free(): invalid pointer 0x1e1f0e0!
    [junit] free(): invalid pointer 0x1e19560!
    [junit] free(): invalid pointer 0x1e3af10!
    [junit] Tests run: 12, Failures: 0, Errors: 0, Time elapsed: 1.074 sec
    [junit] Tests run: 6, Failures: 0, Errors: 0, Time elapsed: 0.075 sec
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.011 sec
    [junit] Tests run: 6, Failures: 0, Errors: 0, Time elapsed: 0.032 sec
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.109 sec
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.009 sec
    [junit] Tests run: 5, Failures: 0, Errors: 0, Time elapsed: 0.05 sec
    [junit] SIGSEGV in VM code.
    [junit] Stack trace:
    [junit] Tests run: 1, Failures: 0, Errors: 1, Time elapsed: 0 sec
    [junit] Tests FAILED (timeout)
<...>

Also some tests in other modules failed.
If someone wants to investigate tests behavior in this environment
I'll share results of my run when it finished.

 Thanks, Vladimir

Mime
View raw message