harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elena Semukhina" <elena.semukh...@gmail.com>
Subject Re: [drlvm][cunit test] cunit test 'test_ti_instrum' intermittently failed on x86_64
Date Tue, 13 Feb 2007 10:05:34 GMT
On 2/13/07, Elena Semukhina <elena.semukhina@gmail.com> wrote:
>
>  On 2/13/07, Vladimir Ivanov <ivavladimir@gmail.com> wrote:
> >
> > For the last day I saw 3 intermittent failure of drlvm cunit test
> > 'test_ti_instrum' on x86_64 platform with log:
> > ---- Execution log --------------------------------
> > ## Executing C unit test: test_ti_instrum
> > INFO: TEST test_jthread_get_all_threads start
> > INFO: TEST test_jthread_get_all_threads: PASSED
> > INFO: TEST test_jthread_get_thread_count start
> > INFO: TEST test_jthread_get_thread_count: PASSED
> > INFO: TEST test_jthread_get_blocked_count start
> > ERROR: Test failed: Wrong number waiting on monitor threads
> > (/export/cruise/trunk/cc/projects/drlvm/trunk/vm/tests/unit/thread/test_ti_instrum.c:139)
> >
> > INFO: TEST test_jthread_get_blocked_count: FAILED
> > ## TEST FAILED
> > ----------------------------------------------------------
> >
> > Could somebody reproduce/fix it?
>
>
>
>  There is https://issues.apache.org/jira/browse/HARMONY-3018 for this
> issue. It seems to be a test issue. I'm looking at it.
>


I attached the patch to
https://issues.apache.org/jira/browse/HARMONY-3018 which
fixes the test.
I ran the test in a loop on linux x86, x86_64 and it passed. Gregory/Alexey
V., would you evaluate?

Elena

  Elena
>
>
> > Thanks, Vladimir
> >
>
>
>
> --
> Thanks,
> Elena




-- 
Thanks,
Elena

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message