harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Zvolsky" <i.zvol...@gmail.com>
Subject Re: [general] Harmony enabling at Windows / x86_64
Date Wed, 21 Feb 2007 04:45:30 GMT
On 2/20/07, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
>
> Thanks Ivan, the build was successful this time. However, I've spent
> some time trying to resolve strange x32-x64 conflict (even with your
> new patch) and found that "clean" target doesn't work as expected. And
> it seems that the root cause of it is your modification:
>
> in modules\portlib\src\main\native\thread\makefile:
> ---
> BUILDFILES = \
>   $(SHAREDSUB)thread_copyright.obj $(HY_PLATFORM)/thrhelp.obj
> $(HY_PLATFORM)/thrspinlock.obj \
>   $(SHAREDSUB)hythread.obj $(SHAREDSUB)hythreadinspect.obj
> $(SHAREDSUB)rwmutex.obj thrdsup.obj \
>   $(SHAREDSUB)thrprof.obj
>
> in modules\portlib\src\main\native\common\windows\makefile:
> --
> BUILDFILES = \
>         $(SHAREDSUB)libglob.obj $(SHAREDSUB)iohelp.obj \
>         $(SHAREDSUB)exceptions.obj $(SHAREDSUB)strhelp.obj \
>         $(HY_PLATFORM)/locklbl.obj lock386.obj \
>         $(SHAREDSUB)utf8decode.obj $(SHAREDSUB)utf8encode.obj
>
> I mean "$(HY_PLATFORM)/thrspinlock.obj" and
> "$(HY_PLATFORM)/locklbl.obj". Seems Windows del command cannot handle
> "/". Could you fix this somehow please?


Well, since these makefiles are intended to work on windows, replacing slash
with backslash should work. I just tried this and it worked fine. So I've
updated the patch in H-3188.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message