harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Beyer" <ndbe...@apache.org>
Subject [buildtest] Does trunk work out of the box yet?
Date Tue, 13 Feb 2007 03:49:38 GMT
I've been struggling with the 'buildtest' system for the past couple
of days. Is anyone else able to run from clean check out of trunk?

I'm trying to run the builds on a W2K SP4 machine. I installed VS2003
and SP1. I've tried running buildtest system using Sun JDK 6 and JDK
5.0_11.

The first problem I ran into was a checksum failure on the msvcr71.dll
copied from my WINNT/system32 folder. Anyone seeing this?

After several attempts I finally got 'ant setup' to complete. When I
just run 'ant', as the README says, to start up CC, I get a Windows
error dialog from the "public" JRE saying that it can't find the main
method of a class. I found it odd that it was launching something with
the "public" JRE as that wasn't first in the path. After clicking OK,
the startup continued and seemed to work fine. I tried to load the web
app, but I recieved an error, Jetty couldn't load the
"org/apache/tools/ant/BuildException" class.

I uninstalled the public JRE, which was Sun's JDK 6, and tried to run
it again with just Sun's JDK 5.0_11 on the path. I tried starting up
the server again. This time I was given a Windows dialog asking what
program to open the "ant.jar" file yet. I close that dialog and tried
the web app again with the same result.

Any thoughts?

-Nathan

Mime
View raw message