harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Zakharov" <alexei.zakha...@gmail.com>
Subject Re: [general] Harmony enabling at Windows / x86_64
Date Wed, 21 Feb 2007 20:28:33 GMT
In my previous letter I was talking about HARMONY-3188 - the classlib
part of the patch. As far as I understand Gregory is currently working
on the DRLVM part. So we will have a full set soon.

Thanks,

2007/2/21, Alexei Zakharov <alexei.zakharov@gmail.com>:
> Ok. I've merged all these files together and committed at r510043. Please note:
>
> 1. The dependence on ICU 3.6 was dropped. So we still use the version
> 3.4 . IMHO moving to ICU 3.6 should be a separate task, separate JIRA
> should be created and etc.
> 2. I've tested the build on Windows 64 and on 32-bit versions of
> Windows and Linux as well. MSVC 2003 was used on Win32 and MSVC 2005
> on Win64. So I currently don't know is it possible to build the
> classlib using MSVC 2005 on Win32.
> 3. I've added compiled 64-bit version of ICU libs to our depends
> folder: as depends/oss/icu4c-3.4-harmony-windows.x86_64.zip and four
> libs to depends/libs/windows.x86_64
> 4. I put the 64-bit variant of precompiled graphic libs (needed by
> awt-swing) to my home folder at people.apache.org. If someone wants to
> propose another place for these files - he/she is welcome. :)
>
> With Best Regards,
>
> 2007/2/21, Ivan Zvolsky <i.zvolsky@gmail.com>:
> > On 2/20/07, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
> > >
> > > Thanks Ivan, the build was successful this time. However, I've spent
> > > some time trying to resolve strange x32-x64 conflict (even with your
> > > new patch) and found that "clean" target doesn't work as expected. And
> > > it seems that the root cause of it is your modification:
> > >
> > > in modules\portlib\src\main\native\thread\makefile:
> > > ---
> > > BUILDFILES = \
> > >   $(SHAREDSUB)thread_copyright.obj $(HY_PLATFORM)/thrhelp.obj
> > > $(HY_PLATFORM)/thrspinlock.obj \
> > >   $(SHAREDSUB)hythread.obj $(SHAREDSUB)hythreadinspect.obj
> > > $(SHAREDSUB)rwmutex.obj thrdsup.obj \
> > >   $(SHAREDSUB)thrprof.obj
> > >
> > > in modules\portlib\src\main\native\common\windows\makefile:
> > > --
> > > BUILDFILES = \
> > >         $(SHAREDSUB)libglob.obj $(SHAREDSUB)iohelp.obj \
> > >         $(SHAREDSUB)exceptions.obj $(SHAREDSUB)strhelp.obj \
> > >         $(HY_PLATFORM)/locklbl.obj lock386.obj \
> > >         $(SHAREDSUB)utf8decode.obj $(SHAREDSUB)utf8encode.obj
> > >
> > > I mean "$(HY_PLATFORM)/thrspinlock.obj" and
> > > "$(HY_PLATFORM)/locklbl.obj". Seems Windows del command cannot handle
> > > "/". Could you fix this somehow please?
> >
> >
> > Well, since these makefiles are intended to work on windows, replacing slash
> > with backslash should work. I just tried this and it worked fine. So I've
> > updated the patch in H-3188.
> >


-- 
Alexei Zakharov,
Intel ESSD

Mime
View raw message