harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Naveen Neelakantam <neela...@uiuc.edu>
Subject Re: [build-test] doesn't work OOB?
Date Thu, 25 Jan 2007 01:31:01 GMT
I was getting that error too!

I could not for the life of me figure out what was going on.  I even  
wrote a test ant script that uses replaceregexp, and it worked fine.   
Go figure.

I looked through the build file and discovered that replaceregexp is  
only run as a postprocessing step in the case of some failures.  So,  
get rid of the failures and the problem should go away.

The errors for me were actually being caused by a large number of  
OutOfMemoryErrors.  I worked around that problem by following  
Vladimir Ivanov's suggestion:
"As workaround to enable new platform and define problem tests you  
can run these tests in the 'perTest' mode for a while (new vm will be  
started for each test).  Please, uncomment the line 238 (<!--jvmarg  
arg="- Dhy.test.forkmode=perTest"/-->) in the configuration to do it."

That worked, and I sort of left the issue there.  I can run the  
classlib tests now and I'm happy.

Naveen

On Jan 24, 2007, at 7:07 PM, Geir Magnusson Jr. wrote:

> Ok - I had a small local problem, but I'm still not able to run  
> everything passing.  For classlib-drlvm, I get :
>
>
> BUILD FAILED
> Ant Error Message:	/home/geir/dev/apache/harmony/enhanced/buildtest/ 
> trunk/cc/projects/classlib/trunk/build.xml:167: The following error  
> occurred while executing this line: /home/geir/dev/apache/harmony/ 
> enhanced/buildtest/trunk/cc/projects/classlib/trunk/make/build- 
> test.xml:289: Could not create task or type of type: replaceregexp.  
> Ant could not find the task or a class this task relies upon.
>
> This seems to be misleading, because the necessary class is in the  
> ant.jar...
>
> Any thoughts?
>
> geir
>
>
> On Jan 24, 2007, at 12:44 PM, Geir Magnusson Jr. wrote:
>
>> OOB == out of the box
>>
>> I tried to do a fresh checkout of build-test on two different  
>> machines, and it doesn't work OOB.  I'm going to figure out why  
>> when I get back from the gym, but if anyone has a timesaving hint,  
>> let me know (and I'll fix it).
>>
>> I also want to switch it to use the federated tree if no one minds  
>> (at some point).
>>
>> geir
>>
>


Mime
View raw message