harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vladimir Ivanov" <ivavladi...@gmail.com>
Subject Re: [classlib][portlib] the portlib tests failed to compile on Windows platform
Date Wed, 24 Jan 2007 13:48:59 GMT
On 1/24/07, Mark Hindess <mark.hindess@googlemail.com> wrote:
>
>
> On 24 January 2007 at 18:54, "Vladimir Ivanov" <ivavladimir@gmail.com>
> wrote:
> >
> > Seems, it does not work :(
>
> What is the output in the generated test report?  You can browse to it
> but it will probably be in a file called:
>
> build/test_report/html/native/portlib/1_hyfile-out.txt
>
> FYI: I've added more verbose errors to the latest version in svn.

Output is (which file should be deleted?):
hyfile:
  portlib initialized
  fd = 4012
  hyfile_write wrote 7 bytes
hyfile_move failed (183) Cannot create a file when that file already exists.

> Output is (note, it does not depend on if/unless in the string <target
> > name="-test-module" unless/if="test.portlib"):
> >
> > support-jar:
> >       [jar] Building jar:
> > C:\harmony.top\classlib\trunk\deploy\build\test\support.jar
> > test-modules:
> > -compile-native-tests:
> > -run-native-tests:
> >     [mkdir] Created dir: C:\harmony.top\classlib\trunk\build\test_report
> >      [echo] init: passed
> >      [echo] hyerror: passed
> >      [echo] hytime: passed
> >      [exec] Result: 1
> >      [echo] hyfile: FAILED
> > touch-errors-file:
> > -test-module:
> > -check-for-empty:
> > -process-empty:
> > process-empty:
> > full-report:
> >
> > but if you add 'if="test.portlib"' to the targets
> '-compile-native-tests'
> > and '-run-native-tests' no tests will be run and
>
> Hmm... I didn't realise depends were executed even when if/unless
> conditions fail.  Fixed now.


Thanks, the "ant -Dbuild.module="p*" test" passed for me now.

> build failed on the
> > '-check-for-empty' target only with message "build\test_report not
> found".
>
> This is really a bug/feature of make/build-test.xml.
>
> Regards,
> Mark.
>
> > On 1/24/07, Mark Hindess <mark.hindess@googlemail.com> wrote:
> > >
> > >
> > > On 24 January 2007 at 15:53, "Vladimir Ivanov" <ivavladimir@gmail.com>
> > > wrote:
> > > >
> > > > Thanks Mark,
> > > > now these tests compiled on windows platform but one of them failed:
> > > > -run-native-tests:
> > > >     [mkdir] Created dir:
> C:\harmony.top\classlib\trunk\build\test_report
> > > >      [echo] init: passed
> > > >      [echo] hyerror: passed
> > > >      [echo] hytime: passed
> > > >      [exec] Result: 1
> > > >      [echo] hyfile: FAILED
> > > >
> > > > Also these tests continue to hang up on x86_64 platform.
> > > > May be special key (-Drun.native.tests=true) will be useful for the
> time
> > > of
> > > > development infrustructure for first native tests?
> > > >  thanks, Vladimir
> > >
> > > I've added test.portlib but I'd really like to understand why it fails
> > > on windows.  Please can someone test it with:
> > >
> > > ant -Dbuild.module=portlib -Dtest.portlib=true test
> > >
> > > and then look at:
> > >
> > > build/test_report/html/native/portlib/1_hyfile-out.txt
> > >
> > > Regards,
> > > -Mark.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message