harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [classlib] libXmu-dev and libxtst-dev
Date Thu, 25 Jan 2007 15:33:15 GMT

On 25 January 2007 at 10:12, "Geir Magnusson Jr." <geir@pobox.com> wrote:
>
> I recently started working again in ubuntu5 in parallels on the mac  
> for real (tired of carrying the ubuntu laptop around too...), and I  
> noticed that to get awt tests to run, I needed to install both libxmu- 
> dev and libxtst-dev, even though the non-dev versions were around.
> 
> Why do we need the -dev versions of these?
> 
> And is this documented?  I looked at the getting started docs and  
> other things, and couldn't find anything.

The awt code attempts to load the unversioned, libXmu.so, rather than
the versioned, libXmu.so.6 (for X11R6).  Debian-based distributions
don't include these unversioned files in their non-dev packages.

I think we decided that we should attempt to load the known-good
versioned .so files first and if that fails try to load the unversioned
.so.

Regards,
 Mark.



Mime
View raw message