harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey Varlamov" <alexey.v.varla...@gmail.com>
Subject Re: [general][testing] CC is failed to run classlib tests and start eclipse over DRLVM
Date Fri, 15 Dec 2006 11:01:48 GMT
2006/12/15, Geir Magnusson Jr. <geir@pobox.com>:
>
>
> Tim Ellison wrote:
> > Geir Magnusson Jr. wrote:
> >> Weird.  I respun snapshots yesterday using r486606 (haven't uploaded
> >> yet) and I'm using it now on Ubuntu 6 x86 to run eclipse.  It works.
> >
> > I'm confused about the state of the world -- are you still trying to get
> > a good snapshot for everyone to bless?  i.e. do we still need to defer
> > any potentially long pieces of work?
>
> Well, I too was trying to figure out the state of the world.
>
> I have a set that I'm testing, but I'm nervous because I have no clue
> what happened this morning.
>
> I thought the VMI change had no relation to solving the CC breakage,
> because I thought the VMI change was simply to remove the ambiguity in
> the API that surfaced when Ollie assumed something which wasn't clear,
> and Gregory fixed it....

To clarify the situation around VMI, Gregory's fix was not fully
correct: it initialized bootstrapClassPath = NULL for the first
iteration so accessibility.jar (or whateevr goes #1 in the
bootstrap.properties) was never added to BCP, causing those swing &
eclipse failures. Thus if your snap is taken before [r487009], it may
be not good.

>
> So I'll do more testing on those snaps tonight, get them out there for
> people to eval and vote and, and then put on site and move forward.
>
> I haven't been able to look at the JTabbedPane() bug that was pointed
> out, and I still think it's there.  Did anyone get a chance to look at it?
>
> geir
>
>

Mime
View raw message