harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: [classlib][nio] DatagramChannelTest failure
Date Mon, 04 Dec 2006 09:26:11 GMT
Aha, the first message contained a stack. I have a mad idea that a
virus is trying to overflow a datagram buffer.

On 12/2/06, Alexei Fedotov <alexei.fedotov@gmail.com> wrote:
> Alexei,
> Is a root cause the same for all failures? Could you please post a stack trace?
>
> On 12/1/06, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
> > Hi Andrew & Alexei,
> >
> > I run tests on my t42p laptop with Windows XP SP2. Ant clean + svn
> > update + full restart doesn't help - I still can see these 9 errors.
> > I guess something is wrong with my network config. Perhaps it is the
> > result of the latest windows update . The exact list of failing tests
> > is the following:
> >
> > testSend_NoServerTwice
> > testSend_NoServerNonBlockingTwice
> > testReceiveSend_Block_Empty
> > testReceiveSend_NonBlock_Empty
> > testReceiveSend_Block_Empty_S2C
> > testReceiveSend_NonBlock_Empty_S2C
> > testReceiveSend_Block_Empty_C2S
> > testReceiveSend_NonBlock_Empty_C2S
> > testReceiveSend_Empty_S2S
> >
> > Thanks,
> >
> > 2006/12/1, Andrew Zhang <zhanghuangzhu@gmail.com>:
> > > Hi Alexei,
> > >
> > > What's your platform? The test passes on my machine (Windows XP, SP2) with
> > > latest code.
> > >
> > > Thanks!
> > >
> > >
> > > On 12/1/06, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
> > > >
> > > > Hi all,
> > > >
> > > > Today 9 tests from the above test class fail on my machine with the
> > > > following message:
> > > >
> > > > ---
> > > > (10040) A message sent on a datagram socket was larger than the
> > > > internal message buffer or some other network limit, or the buffer
> > > > used to receive a datagram into was smaller than the datagram itself.
> > > >
> > > > java.net.SocketException: (10040) A message sent on a datagram socket
> > > > was larger than the internal message buffer or some other network
> > > > limit, or the buffer used to receive a datagram into was smaller than
> > > > the datagram itself. at
> > > > org.apache.harmony.luni.platform.OSNetworkSystem.sendDatagramImpl(Native
> > > > Method) at org.apache.harmony.luni.platform.OSNetworkSystem.sendDatagram(
> > > > OSNetworkSystem.java:142)
> > > > at org.apache.harmony.nio.internal.DatagramChannelImpl.send(
> > > > DatagramChannelImpl.java:348)
> > > > at
> > > > org.apache.harmony.nio.tests.java.nio.channels.DatagramChannelTest.testSend_NoServerTwice
> > > > (DatagramChannelTest.java:1155)
> > > > at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:25)
> > > > ---
> > > >
> > > > However, yesterday it works fine. Does anyone have ideas why it starts
to
> > > > fail?
> > > > --
> >
> > --
> > Alexei Zakharov,
> > Intel Enterprise Solutions Software Division
> >
>
>
> --
> Thank you,
> Alexei
>


-- 
Thank you,
Alexei

Mime
View raw message