harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nina Rinskaya" <nina.rinsk...@gmail.com>
Subject Re: [testing] Eclipse Unit Tests run under Cruise Control
Date Wed, 27 Dec 2006 06:39:00 GMT
On 12/26/06, Alexey Petrenko <alexey.a.petrenko@gmail.com> wrote:
> I've reverted ResourceBundle changes.
> Please verify.
>
> SY, Alexey
>

Alexey,

Eclipse Unit Tests and Eclipse 'Hello World' scenario pass ok now!

Thanks,
Nina

> 2006/12/25, Nina Rinskaya <nina.rinskaya@gmail.com>:
> > Ivan,
> >
> > Thanks for your reply, it really helped.
> >
> > I made the changes (below, just rolling back one of '489307' commit
> > modifications) and Eclipse started successfully and EUT passed ok:
> >
> > *****************************************
> > Index: modules/luni/src/main/java/java/util/ResourceBundle.java
> > ===================================================================
> > --- modules/luni/src/main/java/java/util/ResourceBundle.java
> > (revision 489307)
> > +++ modules/luni/src/main/java/java/util/ResourceBundle.java    (working copy)
> > @@ -268,10 +268,7 @@
> >                        Class<?> bundleClass =
> > Class.forName(bundleName, true, loader);
> >                        bundle = (ResourceBundle) bundleClass.newInstance();
> >                        bundle.setLocale(locale);
> > -               } catch (LinkageError e) {
> > -               } catch (ClassNotFoundException e) {
> > -        } catch (IllegalAccessException e) {
> > -        } catch (InstantiationException e) {
> > +               } catch (Exception e) {
> >         }
> >
> >                if (bundle == null) {
> > *****************************************
> >
> > When I checked Eclipse startup and EUT tests on my Linux (SLES 9)
> > machine, there has been ClassCastException thrown, which is not caught
> > after r489307. Maybe ClassCastException should be added to the
> > 'catch'-es list or it should be fixed in another way.
> >
> > Thanks,
> > Nina
> >
> > On 12/25/06, Ivan Popov <ivan.g.popov@gmail.com> wrote:
> > > I see the following diagnostics in .LOG file after Eclipse silently died:
> > >
> > > java.lang.ExceptionInInitializerError
> > >       at org.eclipse.jface.bindings.keys.SWTKeySupport.<clinit>(SWTKeySupport.java:33)
> > >       at org.eclipse.ui.internal.keys.BindingService.<init>(BindingService.java:93)
> > >       at org.eclipse.ui.internal.Workbench.initializeDefaultServices(Workbench.java:1247)
> > >       at org.eclipse.ui.internal.Workbench.init(Workbench.java:1060)
> > >       at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1844)
> > >       at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:417)
> > >       at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java)
> > >       at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:96)
> > >       at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:77)
> > >       at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
> > >       at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:66)
> > >       at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:396)
> > >       at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
> > >       at java.lang.reflect.VMReflection.invokeMethod(Native Method)
> > >       at java.lang.reflect.Method.invoke(Unknown Source)
> > >       at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
> > >       at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
> > >       at org.eclipse.core.launcher.Main.run(Main.java:975)
> > >       at org.eclipse.core.launcher.Main.main(Main.java:952)
> > > Caused by: java.lang.ClassCastException
> > >       at java.util.ResourceBundle.handleGetBundle(ResourceBundle.java:269)
> > >       at java.util.ResourceBundle.handleGetBundle(ResourceBundle.java:311)
> > >       at java.util.ResourceBundle.handleGetBundle(ResourceBundle.java:311)
> > >       at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:159)
> > >       at java.util.ResourceBundle.getBundle(ResourceBundle.java:87)
> > >       at org.eclipse.jface.bindings.keys.formatting.NativeKeyFormatter.<clinit>(NativeKeyFormatter.java:60)
> > >       at org.eclipse.jface.bindings.keys.SWTKeySupport.<clinit>(SWTKeySupport.java:33)
> > >       ... 18 more
> > >
> > > Hope this can help in identifying problem.
> > >
> > > Thanks.
> > > Ivan
> > >
> > > On 12/22/06, Nina Rinskaya <nina.rinskaya@gmail.com> wrote:
> > > > Hi all,
> > > >
> > > > That's just to let you know that I run Eclipse Unit Tests under Cruise
> > > > Control on Linux (SLES 9)/ia32 and windows (xp)/ia32. During last 10
> > > > days Alexey Ignatenko and I worked on enabling EUT on Harmony and have
> > > > increased EUT pass rate from ~60% up to 93-95% (not taking into
> > > > account some intermittent failures). Many-many thanks to Alexey
> > > > Ignatenko for all his great work.
> > > >
> > > > Does it make sense to report EUT regressions to the mailing list?
> > > >
> > > > Well, first try. Today my local Cruise Control reported significant
> > > > EUT pass rate downgrade with similar failures logs, and Eclipse failed
> > > > to start (silently died after "Select Workspace" dialog). It looks
> > > > like it is caused by commit r489307 - just comparing classlib
> > > > rollbacks to r489307 (Eclipse dies, some EUT tests fail) and r489306
> > > > (Eclipse 'Hello world' passes, EUT tests pass as usually). Could
> > > > anybody take a look at this issue please?
> > > >
> > > > Thanks,
> > > > Nina
> > > >
> > >
> >
>

Mime
View raw message