harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Shimansky <gshiman...@gmail.com>
Subject Re: [dlrvm][jit][opt][x86_64] Running on Jitrino.OPT causes NPE on classlib code
Date Fri, 01 Dec 2006 00:56:38 GMT
Gregory Shimansky wrote:
> Hello
> 
> Today while trying to run acceptance tests on x86_64 I've found that 
> kernel tests fail from the first test in pure Jitrino.OPT (-Xem:opt) 
> mode. I've tried running simple hello world application, and it does not 
> work any more. The NPE happens in class loader code before the main class.
> 
> I know x86_64 is still not a very stable architecture, but this is 
> clearly a regression. I try to do all my commits checking on x86_64 
> Linux. Starting from today no program work at all. This is strange 
> considering that I didn't see any significant commits to Jitrino for the 
> last 2 days.
> 
> I've reproduced it on SuSE9 x86_64 and Gentoo x86_64. On SuSE10 x86_64 
> something even worse has happened, need to investigate if anything at 
> all works on it so far (I mean Harmony, the system itself is ok).

On SuSE10 the same problem is reproducible. In normal conditions hello 
world application is executed, on opt it fails with NPE.

> Here is the stack trace. If I understand it correctly, the code SIGSEGVs 
> in java.net.URLClassLoader.getPermissions and the signal is treated as 
> hardware NPE.
> 
> gashiman@mstmrtd106 ~/work/tests
> $ 
> ../em64t/trunk/working_vm/build/lnx_em64t_gcc_debug/deploy/jre/bin/java 
> Hello
> Hello
> 
> gashiman@mstmrtd106 ~/work/tests
> $ 
> ../em64t/trunk/working_vm/build/lnx_em64t_gcc_debug/deploy/jre/bin/java 
> -Xem:opt Hello
> Uncaught exception in main:
> java.lang.NullPointerException
>         at java.net.URLClassLoader.getPermissions(URLClassLoader.java)
>         at 
> java.lang.ClassLoader$SystemClassLoader.getPermissions(Unknown Source)
>         at java.security.SecureClassLoader.getPD(SecureClassLoader.java)
>         at 
> java.security.SecureClassLoader.defineClass(SecureClassLoader.java:70)
>         at java.net.URLClassLoader.findClassImpl(URLClassLoader.java:1137)
>         at java.net.URLClassLoader$4.run(URLClassLoader.java)
>         at java.net.URLClassLoader$4.run(URLClassLoader.java:1)
>         at java.security.AccessController.doPrivilegedImpl(Unknown Source)
>         at java.security.AccessController.doPrivileged(Unknown Source)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:621)
>         at java.lang.ClassLoader.loadClass(Unknown Source)
>         at java.lang.ClassLoader$SystemClassLoader.loadClass(Unknown 
> Source)
>         at java.lang.ClassLoader.loadClass(Unknown Source)
> FAILED to invoke JVM.


-- 
Gregory


Mime
View raw message