harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Shimansky <gshiman...@gmail.com>
Subject Re: [drlvm] HARMONY-1635 heap iteration WAS: [general] version of GCC...
Date Mon, 06 Nov 2006 21:00:45 GMT
Gregory Shimansky wrote:
> Salikh Zakirov wrote:
>> Gregory Shimansky wrote:
>>
>>> I think you could use 4.1.0 in Fedora Core 5. Since patch level
>>> shouldn't really affect the C++ compilation restrictions, the same patch
>>> should break on 4.1.0 as well.
>>
>> Gregory, I've looked at harmony-1635.patch you've uploaded to 
>> HARMONY-1635,
>> and I see that is based on the outdated patch from HARMONY-1635.
>> (i.e. not the latest version: heap-iteration-optimized.patch).
> 
> Ok I didn't realize which one to take.
> 
>> So I will upload the updated patch myself.
>> I've checked its compilation on Fedora Core 5 (Bordeaux) with gcc 4.1.0,
>> and it compiles okay.
> 
> In this case I think it should be committed. If I get any problems with 
> gcc 4.1.1 (which I don't have at hand right now) I'll try to resolve 
> them myself and create an additional fix.

I can confirm that gcc 4.1.1 compiled this patch without any problems. 
As I've written, patchlevel shouldn't matter here, and if gcc 4.1.0 
worked, 4.1.1 should work as well (with very rare exceptions). I've just 
built VM with it without any errors.


-- 
Gregory


Mime
View raw message