harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexei Fedotov" <alexei.fedo...@gmail.com>
Subject Re: [classlib][nio] DatagramChannelTest failure
Date Thu, 30 Nov 2006 17:41:24 GMT
Alexei,
Could it be that you changed your system to Windows 2003 server?
Datagram tests worked differently for me on the server.

Anyway, please file JIRA issue. Thank you in advance.

On 11/30/06, Alexei Zakharov <alexei.zakharov@gmail.com> wrote:
> Hi all,
>
> Today 9 tests from the above test class fail on my machine with the
> following message:
>
> ---
> (10040) A message sent on a datagram socket was larger than the
> internal message buffer or some other network limit, or the buffer
> used to receive a datagram into was smaller than the datagram itself.
>
> java.net.SocketException: (10040) A message sent on a datagram socket
> was larger than the internal message buffer or some other network
> limit, or the buffer used to receive a datagram into was smaller than
> the datagram itself. at
> org.apache.harmony.luni.platform.OSNetworkSystem.sendDatagramImpl(Native
> Method) at org.apache.harmony.luni.platform.OSNetworkSystem.sendDatagram(OSNetworkSystem.java:142)
> at org.apache.harmony.nio.internal.DatagramChannelImpl.send(DatagramChannelImpl.java:348)
> at org.apache.harmony.nio.tests.java.nio.channels.DatagramChannelTest.testSend_NoServerTwice(DatagramChannelTest.java:1155)
> at java.lang.reflect.AccessibleObject.invokeV(AccessibleObject.java:25)
> ---
>
> However, yesterday it works fine. Does anyone have ideas why it starts to fail?
> --
> Alexei Zakharov,
> Intel Enterprise Solutions Software Division
>


-- 
Thank you,
Alexei

Mime
View raw message