harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Loenko" <mloe...@gmail.com>
Subject Re: [alert] "ant rebuild" is broken
Date Tue, 28 Nov 2006 12:12:48 GMT
classpath has both xerces 2.6.2 and xerces 2.8.0. 2.6.2 goes first.

If I remove 2.6.2 from depends it builds OK. I noticed that there are
also other
old versions of depends that are still there. How do we handle them?

Thanks,
Mikhail

2006/11/28, Tim Ellison <t.p.ellison@gmail.com>:
> Mikhail Loenko wrote:
> > That solves the problem. Let's roll back that change and analyze what
> > happened.
> > Comments?
>
> That was my fix for the broken incremental build problem.
> I am also running on WinXP, and needless to say that I didn't have the
> problem you reported.
>
> Can you touch a java file and run "ant -v build-java", then look at the
> compiler command line to see if it looks reasonable to you?
>
> The problem was that the compiler launch line was including the JARs of
> the JRE that is running Ant, so we were compiling against the RI, and
> not Harmony code.
>
> Thanks
> Tim
>
> --
>
> Tim Ellison (t.p.ellison@gmail.com)
> IBM Java technology centre, UK.
>

Mime
View raw message