harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <g...@pobox.com>
Subject Re: [build] HWA doesn't work
Date Wed, 29 Nov 2006 13:20:31 GMT
What toolset?

Dmitry Irlyanov wrote:
> Mikhail,
> 
> The system was built from the very beginning (svn co))
> This error received after the following command:
> 
> ./java  -classpath . Hello
> 
> May be this exotic output is happen by reason of exotic compiler?
> 
> 2006/11/29, Mikhail Fursov <mike.fursov@gmail.com>:
>>
>> Dmitry,
>> SetBCPElement has become public inside of vmcore module after H2008 is
>> applied. This is the only change I remember for this method.
>> Also it's very strange that you can link DRLVM and get this error on
>> runtime
>> : this method is vmcore library local.
>> Did you try clean build?
>>
>>
>> On 11/29/06, Dmitry Irlyanov <irlyanov@gmail.com> wrote:
>> >
>> > Good day!
>> >
>> > I've successfully build class libraries and DRLVM on Linux, but the
>> build
>> > doesn't work.
>> > After starting Hello World Application the followinng exceptionis
>> thrown:
>> >
>> > Failed to open JVM
>> >
>> >
>> DLL:/drlvm/trunk/build/lnx_ia32_icc_release/deploy/jre/bin/default/harmonyvm(/drlvm/trunk/build/lnx_ia32_icc_release/deploy/jre/bin/default/libharmonyvm.so:

>>
>> > undefined symbol:
>> > _ZN20BootstrapClassLoader13SetBCPElementEPKcP10apr_pool_t)
>> >
>> > Do you know the cause of this error?
>> > Should I add this to JIRA or it is my fault?
>> > _______________
>> > With Best Regards,
>> > Irlyanov Dmitry
>> > Intel Corporation
>> > Middleware Products Division
>> >
>> >
>>
>>
>> -- 
>> Mikhail Fursov
>>
>> _______________
> With Best Regards,
> Irlyanov Dmitry
> Intel Corporation
> Middleware Products Division
> 

Mime
View raw message