harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Ellison <t.p.elli...@gmail.com>
Subject Re: [alert] "ant rebuild" is broken
Date Tue, 28 Nov 2006 12:19:48 GMT
Mikhail Loenko wrote:
> classpath has both xerces 2.6.2 and xerces 2.8.0. 2.6.2 goes first.
> 
> If I remove 2.6.2 from depends it builds OK. I noticed that there are
> also other
> old versions of depends that are still there. How do we handle them?

ah ha.  Yeah, good point.  At the moment we take 'depends/**/*.jar' onto
the classpath, and when we update versions we don't explicitly require
people to delete the older versions.

The fix is to list the dependencies that we have in a fileset, rather
than picking up all the JARs.  It means there is one more place to
update when we have a new dependency, but at least it is explicit I guess.

So I'm guessing that the roll-back fixed things for you because that is
now picking up the 'wrong' JRE JARs again, which happen to have the JARs
you need!  So can you please put back the fixed build-java.xml?

Thanks
Tim

-- 

Tim Ellison (t.p.ellison@gmail.com)
IBM Java technology centre, UK.

Mime
View raw message