harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <g...@pobox.com>
Subject Re: [drlvm] turn on logging, tracing, etc WAS: [drlvm] Anyone able to run Eclipse on WinXP?
Date Tue, 21 Nov 2006 03:16:06 GMT


Nathan Beyer wrote:
> What's the easiest way to enable logging, tracing, etc for DRLVM?
> There are over a dozen -X args for logging, tracing, verbose and I
> can't quite get them to work. I checked the Developer's Guide
> document, but it didn't really match up with the help printed by java
> -X.
> 
> I just want to enable everything and log it to a file. How do I do that?

I thought -Xtrace would do it for you.  That dumps to stderr, and I just 
re-directed to a file.  I was going to fix that so you could 
-Xtrace:*:filename but never got around to it.

In order that we can help, can you tell us what exactly you are doing ?

geir

> 
> -Nathan
> 
> ---------- Forwarded message ----------
> From: Nathan Beyer <nbeyer@gmail.com>
> Date: Nov 20, 2006 6:54 PM
> Subject: Re: [drlvm] Anyone able to run Eclipse on WinXP?
> To: dev@harmony.apache.org
> 
> 
> No, unfortunately I still can't run Eclipse on DRLVM + Classlib.
> 
> The fix I checked in is based on a failing test while running J9 + 
> Classlib.
> 
> -Nathan
> 
> On 11/20/06, Tim Ellison <t.p.ellison@gmail.com> wrote:
>> Is this the problem you fixed as:
>>
>>   Author: ndbeyer
>>   Date: Sun Nov 19 18:27:51 2006
>>   New Revision: 477007
>>
>>   URL: http://svn.apache.org/viewvc?view=rev&rev=477007
>>   Log:
>>   Fix java.net.URI#relativize(URI) to return an empty URI
>>   when an equivalent URI is passed. Update URITest to include
>>   a regression test for this behavior.
>>
>> To answer your question tho', no I haven't tried it.
>>
>> Regards,
>> Tim
>>
>> Nathan Beyer wrote:
>> > I've been trying to run the Eclipse SDK tests, but I can't even get
>> > the OSGi container (Equinox) to run with DRLVM (latest) on WinXP, so
>> > everything comes to a quick halt.
>> >
>> > Here's the error that I'm seeing in the logs for Eclipse 3.2.1. Scroll
>> > down a bit for the root error - Caused by: java.lang.LinkageError:
>> > class org/eclipse/core/internal/runtime/PlatformURLPluginConnection is
>> > defined second time. Anyone have any thoughts? I haven't tried to dig
>> > much farther, so any pointers to the best place to start looking in
>> > the code would be nice.
>> >
>> > !SESSION 2006-11-18 22:51:28.273
>> > -----------------------------------------------
>> > eclipse.buildId=M20060921-0945
>> > java.version=1.5.0
>> > java.vendor=Apache Software Foundation
>> > BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
>> > Command-line arguments:  -os win32 -ws win32 -arch x86
>> >
>> > !ENTRY org.eclipse.equinox.common 4 0 2006-11-18 22:51:30.176
>> > !MESSAGE FrameworkEvent.ERROR
>> > !STACK 0
>> > org.osgi.framework.BundleException: Exception in
>> > org.eclipse.core.internal.runtime.Activator.start() of bundle
>> > org.eclipse.equinox.common.
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1010)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:964)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:315)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:327)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1035)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:491)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

>>
>> >
>> > Caused by: java.lang.LinkageError: class
>> > org/eclipse/core/internal/runtime/PlatformURLPluginConnection is
>> > defined second time
>> >     at java.lang.VMClassRegistry.defineClass(Native Method)
>> >     at java.lang.ClassLoader.defineClass(Unknown Source)
>> >     at
>> > 
>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:160)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:498)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:464)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:427)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:408)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:334)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:385)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:80)

>>
>> >
>> >     at java.lang.ClassLoader.loadClass(Unknown Source)
>> >     at java.lang.Class.forName(Unknown Source)
>> >     at java.lang.Class.forName(Unknown Source)
>> >     at
>> > 
>> org.eclipse.core.internal.runtime.PlatformURLPluginConnection.startup(PlatformURLPluginConnection.java:76)

>>
>> >
>> >     at
>> > 
>> org.eclipse.core.internal.runtime.Activator.installPlatformURLSupport(Activator.java)

>>
>> >
>> >     at 
>> org.eclipse.core.internal.runtime.Activator.start(Activator.java:78)
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:989)

>>
>> >
>> >     at java.security.AccessController.doPrivilegedImpl(Unknown Source)
>> >     at java.security.AccessController.doPrivileged(Unknown Source)
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:985)

>>
>> >
>> >     at
>> > 
>> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:964)

>>
>> >
>> >     ... 9 more
>> >
>>
>> -- 
>>
>> Tim Ellison (t.p.ellison@gmail.com)
>> IBM Java technology centre, UK.
>>

Mime
View raw message