harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefano Mazzocchi <stef...@apache.org>
Subject Re: [gump] Gump running on Harmony!!
Date Wed, 15 Nov 2006 20:50:33 GMT
Gregory Shimansky wrote:
> On Wednesday 15 November 2006 19:27 Stefano Mazzocchi wrote:
>> Great news everyone, I've finally managed to get Gump running with Harmony.
>>
>> Find it at (the semipermanent URL of Geir's server)
>>
>>  http://67.86.14.213:10000/gump/
>>
>> and the 'list of todos' with importance priority can be found at
>>
>>  http://67.86.14.213:10000/gump/project_todos.html
>>
>> The first problem is the lack of "javac" that bootstrap-ant requires.
>>
>> Do we have a solution for that?
> 
> I wonder what is causing those UnsatisfiedLinkErrors at the end of the page. 
> What's wrong with loading libhytext.so and how is it related to finding 
> javac?

First of all, remember that Gump is written in python and uses 'java'
just like any other command, but the environment around that command
might not exactly be the same as the one from the shell. I'm not sure of
the details of that.

Anyway, when Gump starts up, it tries to fire up a bunch of programs
that it expects. I have added those to the path  and I've tested this by
using the sun jvm and achieved the same score of the official gump run.
This tells me that the gump installation is sane.

Now, the only change between the sun gump run and the harmony one is a
change of where JAVA_HOME points to and I wanted to see what happened.

In a perfect world, the score of the harmony gump run would have been
exactly the same as the score on the sun gump run.

This is an indication that the behavior of harmony is different.

So far it's different in two aspects:

 1) there is no javac process in the JAVA_HOME/bin and the bootstrap-ant
module can't work without it

 2) running the 'maven' or 'mvn' scripts fails to load the JVM due to
linkage problems. So either the those scripts fail to setup some native
library-related environment or harmony expects relative paths and might
get screwed by embedded execution in other scripts.

I've just tried to do

 export JAVA_HOME=~/src/harmony/drlvm/build/lnx_em64t_gcc_debug/deploy/jre/

and call "maven", "mvn" and "ant" and all result in the same error

java/lang/UnsatisfiedLinkError : Failed loading library "libhytext.so":
DSO load failed

so it seems that harmony has a problem being launched inside scripts
which is clearly a bug that needs to be fixed.

-- 
Stefano.


Mime
View raw message