harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jimmy, Jing Lv" <firep...@gmail.com>
Subject Re: [testing][nio] 2 tests fail on the SUSE linux
Date Tue, 14 Nov 2006 02:57:36 GMT
Vladimir Ivanov wrote:
> Hello everyone,
> today my cruise control failed on the linux SUSE box with 2 errors in the
> org.apache.harmony.nio.tests.java.nio.channels.SocketChannelTest test.
> Could somebody reproduce/ fix this issue?
> Thanks, Vlaidimir
> 
> Tests testSocket_configureblocking and
> testCFII_ConnectAfterFinish_Server_NonBlock reports ERROR with similar
> output:
> The address is not available
> java.net.BindException: The address is not available at
> org.apache.harmony.luni.platform.OSNetworkSystem.socketBindImpl(Native
> Method) at org.apache.harmony.luni.platform.OSNetworkSystem.bind(
> OSNetworkSystem.java:126) at
> org.apache.harmony.luni.net.PlainSocketImpl.bind(PlainSocketImpl.java:161)
> at java.net.ServerSocket.<init>(ServerSocket.java:116) at
> java.net.ServerSocket.<init>(ServerSocket.java:72) at
> org.apache.harmony.nio.tests.java.nio.channels.SocketChannelTest.setUp(
> SocketChannelTest.java:77)
> 

Hi,

     I have run the test with latest Harmony with IBMVME on SUSE 10 
Enterprise but find nothing wrong.
     However IMO it was "Support_PortManager.getNextPort()" cause the 
problem. This method, as we already know, is unsafe. Thus the test is 
not stable sometimes, though it appears in-frequently.
     We may find a way to fix it, e.g, try to bind to an available port, 
check if successful.


-- 

Best Regards!

Jimmy, Jing Lv
China Software Development Lab, IBM

Mime
View raw message