harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Li" <liyilei1...@gmail.com>
Subject Re: [classlib][General]Problem in plug-in dependencies
Date Wed, 25 Oct 2006 02:59:21 GMT
Thank you, Nathan. It is ok now.:)

On 10/25/06, Nathan Beyer <nbeyer@gmail.com> wrote:
>
> I've updated the build scripts, so the manifests of the source JARs
> shouldn't be causing anymore conflicts. Let me know if this fixes the
> issue.
>
> -Nathan
>
> On 10/24/06, Nathan Beyer <nbeyer@gmail.com> wrote:
> > Ouch. Yeah, the source JARs don't need to use the same MANIFEST file.
> > I'll take a look at that. This explains some of the issues I've been
> > having. Nice catch
> >
> > -Nathan
> >
> > On 10/24/06, Leo Li <liyilei1979@gmail.com> wrote:
> > > It seems that eclipse wrongly load the required jar for a certain
> bundle,
> > > since, for example, luni.jar and luni-src.jar both have the same
> manifest in
> > > which the jar claims it has the require classes for the bundle and
> thus
> > > fuddles eclipse. After I have deleted the manifest from the source
> jar,
> > > every thing recovers. So I recommend to make some modification in
> build
> > > script not to have source jar also claim exporting packages.
> > >
> > > On 10/24/06, Leo Li <liyilei1979@gmail.com> wrote:
> > > >
> > > > Hi, all:
> > > >      After rebuilt current Harmony classlib, I found several source
> jars
> > > > have replaced the binary jar in the classpath of  plug-in
> dependencies, for
> > > > example, the nio-char_src.jar instead of nio-char.jar. Thus it lead
> to the
> > > > failure of project building in eclipse.
> > > >
> > > > --
> > > > Leo Li
> > > > China Software Development Lab, IBM
> > > >
> > >
> > >
> > >
> > > --
> > > Leo Li
> > > China Software Development Lab, IBM
> > >
> > >
> >
>



-- 
Leo Li
China Software Development Lab, IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message