harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Li" <liyilei1...@gmail.com>
Subject [classlib][build]Lacks liblcms.a libpng.a and etc on Linux and recommend to add them to fetch-depends target
Date Sun, 08 Oct 2006 08:39:18 GMT
Hi, all
     Current harmony build script on linux requires liblcms.a libpng.a and
several .h files such as png.h but not installed on my redhat linux
platform. Although as the script prompts out, ubuntu can download such files
seperately, while other platform such as my redhat or suse, rpm might be the
only source to get new softwares from internet which leads to a lot of
troubles. For examples, the dependency between those rpms and the default
installation destinations of these rpms are not the places Harmony script
expects.
     So, I think, it will be good if the build script can download these
required files automatically when they are absent.
-- 
Leo Li
China Software Development Lab, IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message