harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikhail Fursov" <mike.fur...@gmail.com>
Subject Re: [drlvm] debugging on msvc -- getting debug symbols to load
Date Fri, 20 Oct 2006 13:27:16 GMT
Weldon,
I use MSVC 2003 for debugging every day and everything works fine.
Did you try drlvm/trunk/buld/msvc_2003 build? It's not complete (no vmcore,
no gc), but it runs debug session OK to me.


On 10/20/06, Weldon Washburn <weldonwjw@gmail.com> wrote:
>
> Suddenly I am unable to debug msvc 2003.  It won't load the debug
> symbols  I
> tried installing msvc 2005 but it still won't load the debug symbols.
>
> The following seems to work.  Does anyone else see this?  Is there an
> easier
> way to do this?
>
> 1)
> Create a new and empty project
>
> 2)
> On the Project pulldown, select "newproject Properties"
>
> 3)
> put something like the following in the "Command" window
>
> c:\t_harmony\drlvm\trunk\build\win_ia32_msvc_debug\deploy\jre\bin\java.exe
>
> 4)
> put something like the following in the "Command Arguments" window
>
> -Xbootclasspath/p:.;mmtk.jar -Xem:jet -Xms512m -Xms512m -version
> TestSemiSpace  1
>
> 5)
> build the new and empty project to keep msvc happy
>
> 6)
> start debugging -- push F5
>
> NOTE: I like to put an "__asm{int 3}" in the C/C++ code.  This will force
> the binary to always call the debugger.
>
>
>
> --
> Weldon Washburn
> Intel Middleware Products Division
>
>


-- 
Mikhail Fursov

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message