harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Valentin Al. Sitnick (Moscow)" <valentin.aka.an...@gmail.com>
Subject Re: [classlib][em64t]Problems during classlib on em64t (revision 462753)
Date Wed, 11 Oct 2006 14:26:11 GMT
It is very strange but I have needed jdk & jars
-------------------------------------------------------------------
compile-java:
     [echo] Compiling ACCESSIBILITY classes

copy-resources:

svn-info:

build-jar:

BUILD FAILED
/home/angel/builds/harmony/suse-10.1-em64t/clean/classlib/trunk/build.xml:108:
The following error occurred while executing this line:
/home/angel/builds/harmony/suse-10.1-em64t/clean/classlib/trunk/make/build-
java.xml:183: The following error occurred while executing
this line:
/home/angel/builds/harmony/suse-10.1-em64t/clean/classlib/trunk/make/properties.xml:249:
The following error occurred while executing
this line:
/home/angel/builds/harmony/suse-10.1-em64t/clean/classlib/trunk/make/properties.xml:259:
The following error occurred while executing
this line:
/home/angel/builds/harmony/suse-10.1-em64t/clean/classlib/trunk/modules/accessibility/build.xml:90:
No supported regular expression matcher found

Total time: 20 seconds

Linux_x86_64 (bigbox): /home/angel/builds/harmony/suse-10.1-em64t
/clean/classlib/trunk
18:17:24 $ java -version
java version "1.5.0_09"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_09-b01)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_09-b01, mixed mode)

Linux_x86_64 (bigbox): /home/angel/builds/harmony/suse-10.1-em64t
/clean/classlib/trunk
18:19:32 $ ant -version
Apache Ant version 1.6.5 compiled on June 16 2006

Linux_x86_64 (bigbox): /home/angel/builds/harmony/suse-10.1-em64t
/clean/classlib/trunk
18:19:54 $ ls /usr/postinstall/ant/apache-ant-1.7.0Beta2/lib/
ant-antlr.jar            ant.jar           ant-stylebook.jar
ant-apache-bcel.jar      ant-javamail.jar  ant-swing.jar
ant-apache-bsf.jar       ant-jdepend.jar   ant-trax.jar
ant-apache-log4j.jar     ant-jmf.jar       ant-weblogic.jar
ant-apache-oro.jar       ant-jsch.jar      jakarta-oro-2.0.8.jar
ant-apache-regexp.jar    ant-junit.jar     jakarta-regexp-1.4.jar
ant-apache-resolver.jar  ant-launcher.jar  libraries.properties
ant-commons-logging.jar  ant-netrexx.jar   README
ant-commons-net.jar      ant-nodeps.jar    xercesImpl.jar
ant-jai.jar              ant-starteam.jar  xml-apis.jar

Linux_x86_64 (bigbox): /home/angel/builds/harmony/suse-10.1-em64t
/clean/classlib/trunk
18:20:16 $

---------------------------------------------------------------------------------------------









On 10/11/06, Mark Hindess <mark.hindess@googlemail.com> wrote:
>
>
> On 11 October 2006 at 16:18, "Valentin Al. Sitnick (Moscow)" <
> valentin.aka.angel@gmail.com> wrote:
> >
> > Hi,
> >     I've tried to build classlib on em64t workstation an got some
> problems:
> >
> > 0. Bug in depends.xml - hosts architectures defined with bug
> > ---------------
> >         <condition property="hack.arch" value="ipf">
> >             <isset property="is.x86_64" />
> >         </condition>
> > --------------- small fix
> >          <condition property="hack.arch" value="ia64">
> >             <isset property="is.ia64" />
> >         </condition>
> >
> >         <condition property="hack.arch" value="x86_64">
> >             <isset property="is.x86_64" />
> >         </condition>
> >  ---------------
> >
> > 1. ant (1.6.5 or 1.7.0.beta2 - I've tried to use both) cannot create
> > symlinks. It is not serious porblem - it is possible to create these
> lintks
> > manually
> > 2. build process was interrupted by error:
> >
> >
> -----------------------------------------------------------------------------
> > -----------------------------------------------------
> >  -really-link:
> >
> > check:
> >
> > -compile:
> >     [mkdir] Created dir: /home/angel/builds/harmony/suse-10.1-em64t
> > /clean/classlib/trunk/build/classes
> >     [javac] Compiling 3397 source files to
> /home/angel/builds/harmony/suse-
> > 10.1-em64t/clean/classlib/trunk/build/classes
> >     [javac] Note: * uses or overrides a deprecated API.
> >     [javac] Note: Recompile with -Xlint:deprecation for details.
> >     [javac] Note: Some input files use unchecked or unsafe operations.
> >     [javac] Note: Recompile with -Xlint:unchecked for details.
> >     [mkdir] Created dir: /home/angel/builds/harmony/suse-10.1-em64t
> > /clean/classlib/trunk/deploy/jdk/jre/lib/boot
> >
> > call-modules-all:
> >
> > compile-java:
> >      [echo] Compiling ACCESSIBILITY classes
> >
> > copy-resources:
> >      [copy] Copying 1 file to /home/angel/builds/harmony/suse-10.1-em64t
> > /clean/classlib/trunk/build/classes
> >
> > svn-info:
> >
> > build-jar:
> >
> > BUILD FAILED
> > /home/angel/builds/harmony/suse-10.1-em64t
> /clean/classlib/trunk/build.xml:108
> > :
> > The following error occurred while executing
> > this line:
> > /home/angel/builds/harmony/suse-10.1-em64t
> /clean/classlib/trunk/make/build-
> > java.xml:183: The following error occurred while executing
> > this line:
> > /home/angel/builds/harmony/suse-10.1-em64t
> /clean/classlib/trunk/make/properti
> > es.xml:249:
> > The following error occurred while executing
> > this line:
> > /home/angel/builds/harmony/suse-10.1-em64t
> /clean/classlib/trunk/make/properti
> > es.xml:259:
> > The following error occurred while executing
> > this line:
> > /home/angel/builds/harmony/suse-10.1-em64t
> /clean/classlib/trunk/modules/acces
> > sibility/build.xml:90:
> > No supported regular expression ma
> > tcher found
> >
> > Total time: 56 seconds
> >
> > Linux_x86_64 (bigbox): /home/angel/builds/harmony/suse-10.1-em64t
> > /clean/classlib/trunk
> > 14:36:02 $
> >
> >
> -----------------------------------------------------------------------------
> > -----------------
> > It seems as an ant bug.
> > Could someone help me?
>
> I've never seen this error, but it looks like you are missing a regex
> implementation.  The ant regexp glob mapper has some dependencies
> described at:
>
> http://ant.apache.org/manual/CoreTypes/mapper.html#regexp-mapper
>
> But basically it says you need:
>
> Ant comes with implementations for the
> java.util.regex package of JDK 1.4 or higher,
> jakarta-regexp and jakarta-ORO.
>
> I'm kind of surprised you don't have the first of these?
>
> Regards,
> Mark.
>
>
>
>
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message