harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konovalova, Svetlana" <svetlana.konoval...@intel.com>
Subject RE: [build] Building on Eclipse - FYI
Date Thu, 26 Oct 2006 14:11:48 GMT
Folks,
 
I see that we do need one more building doc describing Eclipse
specifics. 
The main doc containing building instructions now is the "Getting
Started for Contributors" page.
[http://incubator.apache.org/harmony/quickhelp_contributors.html].
My suggestion is to add one more section to it describing building
instructions for Eclipse. How about that?

If you need my help, I'll be glad to manage the doc creation:)
  
Cheers,
Sveta

-----Original Message-----
From: Sian January [mailto:sianjanuary@googlemail.com] 
Sent: Thursday, October 26, 2006 4:06 PM
To: harmony-dev@incubator.apache.org
Subject: Re: [build] Building on Eclipse - FYI

Hi Nathan,

Yes - I was trying to run the enitre build in Eclipse and this is always
my
preferred method of building.  There is at least one other extra step
apart
from the one discussed in this thread so I think some additional
documentation would be useful.

Thanks,

Sian



On 25/10/06, Nathan Beyer <nbeyer@gmail.com> wrote:
>
> Are you referring to running the build scripts via Eclipse? Just
> wanted to make sure I understand.
>
> Personally, I only import the module projects one at a time and run
> the full builds outside of Eclipse, so I've never tried this. Perhaps
> some additional documentation on using Eclipse in this fashion. This
> might be helpful additionally.
>
> On 10/24/06, Sian January <sianjanuary@googlemail.com> wrote:
> > Hello,
> >
> > I encountered a problem today building on Eclipse, and I just
thought
> I'd
> > post about it here in case anyone sees the same problem in the
> future.  I
> > was getting the error:
> >
> >
> > BUILD FAILED
> > *
> >
> > C:\eclipse32harmony\eclipse\workspace\Harmony\build.xml:108: The
> following
> > error occurred while executing this line:
> >
> >
C:\eclipse32harmony\eclipse\workspace\Harmony\make\build-java.xml:127:
> The
> > Eclipse compiler class for Ant could not be found. Please place the
ECJ
> JAR
> > in ANT_HOME/lib. The JAR can copied from
> CLASSLIB_TRUNK/depends/jars/ecj_3.2
> > folder after the fetch-depends target has been run.
> > *
> >
> > The solution to this is to copy ecj_3.2.jar into
> > ..\plugins\org.apache.ant_1.6.5\lib and *also* change the Ant
settings
> to
> > include this jar (Window > Preferences > Ant > Runtime then select
> 'Global
> > Entries' then 'Add External Jars' and add ecj_3.2.jar from the
> > org.apache.ant_1.6.5\lib directory).
> >
> > I don't know if many people build on Eclipse, and I know there have
been
> > some conversations about having too many instructions on the
website,
> but
> > since the steps are slightly different for Eclipse I wondered if it
> might be
> > worth augmenting the instructions or adding some Eclipse-specific
ones
> at
> > some point?
> >
> > Sian
> >
> > --
> > Sian January
> >
> > IBM Java Technology Centre, UK
> >
> >
>



-- 
Sian January

IBM Java Technology Centre, UK

Mime
View raw message