harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gregory Shimansky <gshiman...@gmail.com>
Subject Re: Can't get binary to work
Date Mon, 09 Oct 2006 23:17:56 GMT
On Monday 09 October 2006 08:26 Armand Navabi wrote:
> Yes, I am still having problems.
>
> Like I said, I am just trying to run the executable currently.  I see the
> same problem I was seeing when I built the DRLVM.
>
> I downloaded the Latest Linux JRE snapshot build, set the JAVA_HOME, PATH
> and LD_LIBRARY_PATH environment variables and then tried to run helloworld.
> Sometimes the executable will print "hello world!" and then hang, and
> sometimes it will just hang.  Same thing happens when I download and try to
> run the Latest Linux HDK with helloworld.
>
> My platform is Linux Gentoo 2.6.17.8.

I'm just catching up with emails after a week away from internet. I am using 
Gentoo myself and my kernel is 2.6.17-r4. I did a clean rebuild of classlib 
and drlvm to make sure I am up to date with everything that changed while was 
away. When I run java 
from .../drlvm/trunk/build/lnx_ia32_gcc_debug/deploy/jre/bin it works just 
fine, at least for hello world class. There is no reason to set 
LD_LIBRARY_PATH for it.

Also I've noticed that deploy directory is gone from drlvm/trunk/build. I am 
sure I am missing something (2k emails to read yet), maybe I am not using the 
right executable, but as long as it works it is ok to me :)

-- 
Gregory Shimansky, Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message