harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hindess <mark.hind...@googlemail.com>
Subject Re: [classlib][depends] missing liblcms +em64t
Date Wed, 04 Oct 2006 15:10:11 GMT

On 4 October 2006 at 18:26, "Ivan Volosyuk" <ivan.volosyuk@gmail.com> wrote:
> Working on a patch, I've just wanted to check wether it works on em64t.
> It is not that easy as I expected. Yesterday, I have filed
> HARMONY-1676 to have classlib built.
> Today, I have:
> ================
> Missing dependency.  The file from:
>   /usr/lib/liblcms.a
> should be linked to:
>   depends/libs/build/lcms/liblcms.ia32
> 
> But /usr/lib/liblcms.a doesn't exist.
> liblcms development package not installed
> For Debian/Ubuntu try: apt-get install liblcms1-dev
> ================
> 
> First of all, why 'ia32' prefix for em64t build?

One second look, this seems to be a different problem.  It looks like I
accidentally hardcode ia32 - but since that's all that we really support
at the moment then I'm not that sorry.

The wider issue is that for historical reasons the awt build still uses
ia32 and ipf where as it should probably be fixed to use the hy.arch
defines of x86 and x86_64 (and ia64 if necessary but we don't really
cover that yet anyway).

Patches welcome or I'll try to take a look in the next day or so.

Regards,
 Mark.



---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message