harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Durnev" <dmitry.a.dur...@gmail.com>
Subject Re: [classlib][awt] Can't start any AWT app after recent(9/9/06-11/9/06) changes in java.awt
Date Mon, 11 Sep 2006 13:14:14 GMT
I've already found the cause of the problem.
In short: creation of system EventQueue was commented out
in Toolkit constructor because of "the local variable is never read"
compiler warning :)
Variable itself is indeed not used, but the constructor call has some important
side effects...
Will file a JIRA and offer a patch:)

On 9/11/06, Dmitry Durnev <dmitry.a.durnev@gmail.com> wrote:
> Hi all!
>
> After checking out the latest classlib from SVN I get this NPE on any
> AWT app start:
>
> java.lang.NullPointerException
>        at java.awt.ToolkitImpl.getSystemEventQueueImpl(ToolkitImpl.java:525)
>        at java.awt.EventDispatchThread.runModalLoop(EventDispatchThread.java:58)
>        at java.awt.EventDispatchThread.run(EventDispatchThread.java:47)
>
> Tried both with DRLVM and IBM j9 on Windows.
> Anybody has the same problem?
> I'll try to investigate it, but maybe somebody has an idea of what's going on?
>
>
> Dmitry A. Durnev,
> Intel Middleware Products Division
>


-- 

Dmitry A. Durnev,
Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message