harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Leo Li" <liyilei1...@gmail.com>
Subject [classlib][luni]To open warning as error on Linux
Date Mon, 25 Sep 2006 06:15:59 GMT
Hi, all
     I plan to give a patch that fixed all warning in native code of luni on
Linux and then set Werror in luni makefile.
     But now I have a problem: Different versions of gcc have different
definitions of warnings, for example, the file can build on my default
GCC3.0.4 of RH but fails on GCC4.0.3 of my colleague's ubuntu if I set
warning as error on. Although I can fix it on GCC4.0.3, what about other
versions?
    So my question is whether we have our default or reference version of
GCC?:)



-- 
Leo Li
China Software Development Lab, IBM

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message