harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anton Luht" <anton.l...@gmail.com>
Subject Re: [drlvm] Need help debugging
Date Tue, 12 Sep 2006 09:15:35 GMT
Hello,

I'm observing the same problem - ActiveMQ can't start - on DRLVM +
Classlibrary build 442240 .

The problem I see first is that in
<classlib root>\modules\luni\src\main\native\launcher\shared\main.c

in function 'static int invocation' after call 'createVMArgs' variable
'mainClassJar' contains garbale while in the very end of 'static int
createVMArgs' it contains valid string
'org.apache.harmony.kernel.vm.JarRunner' . If we comment out
'hymem_allocate_memory' in that function:

  if (isStandaloneJar)
    {
      if (useDefaultJarRunner == 0)
        {
          //:::commented out:::: mainClassJar = hymem_allocate_memory (50);
          if (mainClassJar == NULL)

the application will crash a little later. Note: we can comment this
out because memory for mainClassJar is already allocated in the
calling method.

I believe that the general problem is that contents of memory alocated
with hymem_allocate_memory get somehow broken on exit from a method.

On 9/9/06, Geir Magnusson Jr. <geir@pobox.com> wrote:
> I applied the GCv4.1 patch and now I pass smoke test.  I suspect it may
> be because the patch modifies the LOS test, but I'm not so sure.
>
> that patch (HARMONY-1269) is a sole-author patch to our existing
> codebase, and while I do have a BCC to put in SVN, I think that this is
> a patch, and not a "bulk contribution", so I'll go forward and commit it.
>
> geir
>
>
> Geir Magnusson Jr. wrote:
> > More news - I'm not passing the smoke tests. gc.LOC just spins (and
> > sucks a lot of memory in).
> >
> > Clearly what I thought were trivial changes to switch to use the
> > launcher had hidden effects.  Any suggestions where to start looking?
> >
> > geir
> >
> > Geir Magnusson Jr. wrote:
> >> I was testing the DRLVM-in-Launcher setup and something is seriously
> >> broken.
> >>
> >> On Ubuntu, both debug and release builds, it will run Tomcat ok, but
> >> when I try something like Eclipse 3.2 or ActiveMQ 4.0.2 the program
> >> runs and silently exits.  No log output, no console output.
> >>
> >> I've been trying to find a hint of what is making it unhappy, but so
> >> far, no luck.
> >>
> >> I've been staring at the output with -Xlog and -Xtrace, and there
> >> doesn't seem to be any errors, but I don't know what to look for.  (
> >>
> >> I've captured the stream and placed it here :
> >>
> >>   http://people.apache.org/~geirm/activemq-logstream-20060909.txt
> >>   http://people.apache.org/~geirm/activemq-tracestream-20060909.txt
> >>
> >> If anyone has any hints, I'd be mighty obliged...
> >>
> >> geir
> >>
> >>
> >> ---------------------------------------------------------------------
> >> Terms of use : http://incubator.apache.org/harmony/mailing.html
> >> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> >> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
> >>
> >
> > ---------------------------------------------------------------------
> > Terms of use : http://incubator.apache.org/harmony/mailing.html
> > To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> > For additional commands, e-mail: harmony-dev-help@incubator.apache.org
> >
>
> ---------------------------------------------------------------------
> Terms of use : http://incubator.apache.org/harmony/mailing.html
> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>
>


-- 
Regards,
Anton Luht,
Intel Middleware Products Division

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message