harmony-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geir Magnusson Jr." <g...@pobox.com>
Subject Re: [drlvm] HARMONY-1363 - problem finding apr_get_thread_time
Date Thu, 14 Sep 2006 06:48:46 GMT


Mikhail Fursov wrote:
> Geir,
> AFAIR the only diff to EM files was the fix of the default JIT library path
> construction. (?)
> Why do you think that the current problem is related to EM?

I don't anymore.  But I get to make stupid mistakes because it's almost 
3am here, I've been up since 3am this morning, but on the other coast of 
the US, and then flew across the continent in an aluminum tube, 
whistling through the air near mach 1 at 37k feet :)

So the problem is that on startup, I get

   undefined symbol : apr_get_thread_time


geir

> 
> On 9/14/06, Geir Magnusson Jr. <geir@pobox.com> wrote:
>>
>> Thanks to Gregory's HARMONY-1459 patch to fix the asm problem, I now
>> have SVN head of DRLVM patched with 1363 and building cleanly.
>>
>> However, I do have a problem running it with the launcher, as some of my
>> "work with launcher" work was undone w/ this patch in DrlEMImpl.cpp
>>
>> The problem is that when firing off the launcher, libharmonyvm.so can't
>> find apr_get_thread_time
>>
>> I know this is one of our patches to APR - I need to see if this was
>> somehow undone somewhere...
>>
>> Any ideas?
>>
>> geir
>>
>>
>> ---------------------------------------------------------------------
>> Terms of use : http://incubator.apache.org/harmony/mailing.html
>> To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: harmony-dev-help@incubator.apache.org
>>
>>
> 
> 

---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: harmony-dev-unsubscribe@incubator.apache.org
For additional commands, e-mail: harmony-dev-help@incubator.apache.org


Mime
View raw message